AnsweredAssumed Answered

ERROR (10009) -  Couldn't connect to the CLDB service.

Question asked by zhao_rock on Feb 2, 2013
Latest reply on Feb 3, 2013 by zhao_rock
Hi team, could you give me some advice
when i install MapR to the step of /opt/mapr/bin/maprcli acl edit -type cluster -user root:fc,
meeting this issue ERROR (10009) -  Couldn't connect to the CLDB service.
So i traced the following logs.
<pre>
disksetup.0.log:
2013-02-01 12:32:54,215 1825 SetCldbRole:920 INFO Create cid = 1 for cldb role
2013-02-01 12:32:54,215 1825 **LoadDiskTab:432 INFO No disktab file: /opt/mapr/conf/disktab**
2013-02-01 12:32:54,215 1825 LoadInputFile:453 INFO Start parsing input file: /root/storagefile

cldb.log
2013-02-01 12:52:43,456 INFO CLDBServer [Lookup-thread-1]: RPC: PROGRAMID: 2345 PROCEDUREID: 5 from 172.28.217.59:1111 Rejecting rpc with status 3 as CLDB is waiting for local kvstore to become master

2013-02-01 12:49:28,630 FATAL CLDB [WaitForLocalKvstore Thread]: CLDBShutdown: **CLDB had master lock and was waiting for its local mfs to become Master.Waited for 7 (minutes)** but mfs did not become Ma
ster. Shutting down CLDB to release master lock.

mfs.log
2013-02-01 12:49:28,9631 ERROR  cldbha.cc:405 x.x.0.0:0 **Got error Connection reset by peer (104) while trying to register with CLDB** IPAddress:7222
2013-02-01 12:49:31,9643 INFO  cldbha.cc:211 x.x.0.0:0 No storage pools are ready on this node. Marking CLDB unreachable

warden.log
2013-02-01 13:07:01,398 ERROR com.mapr.warden.service.baseservice.common.ZKUtilsLocking checkZKNodeForExistence [main-EventThread]: SessionExpiredException while trying to checkZKNodeForExistence of: /services/kvstore/chukwa2
2013-02-01 13:07:01,398 ERROR com.mapr.warden.service.baseservice.DependentService checkifDependentServiceChanged [main-EventThread]: ZK Session was either or closed or expired for service: cldb

ess hoststats.log
2013-02-01 12:42:27,1522 Program: hoststats on Host:  IP: 0.0.0.0, Port: 1111, PID: 2466
2013-02-01 12:49:46,4243 **ERROR Hoststats hoststats.cc:213 Thread: 140385606371072 Oops! Failed to connect to maprfs!**  with error count since last shown error: 0

</pre>
I just installed CLDB<FileServer<JobTracker<NFS<TaskTracker<WebServer<ZooKeeer in one node,because i want to test.

And I supposed **whether my disk is too low**,so lead to the problem.
Used the following command to set a storage
<code>
dd if=/dev/zero of=/root/storagefile bs=1G count=4
</code>
Asking for your help

Outcomes