AnsweredAssumed Answered

How is the /opt/mapr/logs/initaudit.log log file configured?

Question asked by amsimms01 on Feb 15, 2016
Latest reply on Apr 19, 2016 by amsimms01
This file quickly grows to hundreds of megabytes, despite the fact that my cluster is not configured for auditing.  The information in the file is highly repetitive, consisting primarily of lines such as:

    Successfully Set Audit paths for Fileserver and DB
    2016-02-15 22:39:26
    ---- Mon Feb 15 12:51:11 HST 2016 --- ALL OK
    Successfully Set Audit paths for Fileserver and DB
    2016-02-15 22:51:44
    ---- Mon Feb 15 13:03:25 HST 2016 --- ALL OK
    Successfully Set Audit paths for Fileserver and DB
    2016-02-15 23:04:00
    ---- Mon Feb 15 13:15:57 HST 2016 --- ALL OK
    Successfully Set Audit paths for Fileserver and DB

Is there a way to control the growth and frequency of these audits?  I will note that auditing is not currently enabled:

    $ maprcli audit info -json
    {
        "timestamp":1455578812969,
        "timeofday":"2016-02-15 01:26:52.969 GMT-1000",
        "status":"OK",
        "total":1,
        "data":[
            {
                "data":{
                    "enabled":"0",
                    "maxSizeGB":"32",
                    "retentionDays":"30"
                },
                "cluster":{
                    "enabled":"0",
                    "maxSizeGB":"NA",
                    "retentionDays":"NA"
                }
            }
        ]
    }
    



Outcomes