AnsweredAssumed Answered

oozie timezone representation

Question asked by ramgade on Dec 30, 2015
- we are running a two node test server. i am trying to schedule map reduce jobs using oozie coordinator.
 - Have created oozie workflow and properties file.
when submitting jobs manually from working all fine and results are consistent.
problem arises when trying to schedule these workflow
using coordinator.
 coordinator.xml

      <workflow>
         <app-path>${workflowPath}</app-path>
         <configuration>
                 <property>
                    <name>start_date</name>
                    <value>${startTime}</value>
                 </property>
                 <property>
                    <name>jobTracker</name>
                    <value>${jobTracker}</value>
                </property>
                <property>
                    <name>nameNode</name>
                    <value>${nameNode}</value>
                </property>
                <property>
                    <name>queueName</name>
                    <value>${queueName}</value>
                </property>
         </configuration>
      </workflow>
   

 - coordinator.properties file

nameNode=maprfs:///

jobTracker=maprfs:///

queueName=default

freq=60

startTime=2015-12-30T14:40Z

endTime=2015-12-30T15:40Z

oozie.use.system.libpath=true

oozie.coord.application.path=maprfs:/user/mapr/mapr-coordinators/

workflowPath=maprfs:/user/mapr/abcd-oozie-example/

tried various permutation and combination to set time zone correctly,,utc is only option that is showing correct schedule. but job is not excepting at expected time
if i set to "IST" ; job is scheduled for +5 hrs from current time , same with GMT+05:30.
we are based in hyderabad, india.so what is the correct time zone to be mentioned  in xml file as well in oozie GUI settings

Outcomes