AnsweredAssumed Answered

How do I run configure.sh on a MapR (5.0.0.32987.GA) M3 system to configure Hive ?

Question asked by ozzielabrat on Nov 25, 2015
Latest reply on Nov 26, 2015 by mufeed
Hi,

We have a running MapR M3 system (version 5.0.0.32987.GA) with 3 x Control Nodes and 1 x Client Node.

The system was setup using the following command and new configuration file:

[root@{controlnode1_server]#  **/opt/mapr-installer/bin/install -u root -U root --cfg /opt/mapr-installer/bin/ondemand.config new**

I can upload the log file produced by the above command if need be.

I can connect to MCS via https://{node1_TCPIP_Number}:8443/ (which shows all 3 x Control Nodes).

I am trying to setup Hive to run on the Client Node....using the MapR URL:

     http://doc.mapr.com/display/MapR/Installing+Hive


The MapR installer successfully copied the required Hive packages to the client node:

[root@{client1_server}]#  **rpm -qa | grep -i hive**

     mapr-hivemetastore-1.2.201509240901-1.noarch
     mapr-hive-1.2.201509240901-1.noarch
     mapr-hiveserver2-1.2.201509240901-1.noarch


I've also edited the respective config file (/opt/mapr/hive/hive-1.2/conf/hive-site.xml) and have setup what I believe to be correct settings (again as per the MapR URL above).

However, when I run the configure script mentioned in the MapR URL, this is what happens:

[root@{client1_server}]#  **/opt/mapr/server/configure.sh -R**

     Configuring Hadoop-2.7.0 at /opt/mapr/hadoop/hadoop-2.7.0
     Done configuring Hadoop
     grep: /opt/mapr/conf/warden.conf: No such file or directory
     ERROR: Zookeeper nodes list is not available. Please use -C and -Z parameters to configure the node.
     Exiting

Is there a MapR Guru out there who can advise me on what I am doing wrong ?

I didn't particularly want Warden to be responsible for starting/stopping Hive....but perhaps I need to ?

Is it PEBCAK ?   If so, I am willing to learn what I need to do.

Thanks,

Damion.









Outcomes