AnsweredAssumed Answered

issue during installation

Question asked by prashanth on Nov 25, 2015
Latest reply on Dec 4, 2015 by davidtucker
I am getting the below issue when installing MapR using MapR installer. Request your help on issue.

I have selected the services, given the details of the databases, clusters and nodes. During the verification phase i am getting the error.




install log
====================

2015-11-09 13:22:19.942: launched python script with pid 13901
/opt/mapr/installer/build/installer/lib/python2.7/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)
Can't connect to HTTPS URL because the SSL module is not available.
Traceback (most recent call last):
  File "/opt/mapr/installer/bin/install.py", line 85, in run
    InstallRunner(args.cfg, **args_dict)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinstaller-5.0.0.ui1.1.83-py2.7.egg/maprinstaller/runner/installrunner.py", line 89, in __init__
    self.run()
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinstaller-5.0.0.ui1.1.83-py2.7.egg/maprinstaller/runner/installrunner.py", line 208, in run
    self.cb_logger.process("{0} on {1}".format(label, group))
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinstaller-5.0.0.ui1.1.83-py2.7.egg/maprinstaller/callbacks.py", line 97, in process
    self.patch(url, headers, json.dumps(payload))
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinstaller-5.0.0.ui1.1.83-py2.7.egg/maprinstaller/callbacks.py", line 44, in patch
    response = self.session.patch(url, data=payload, headers=headers)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests/sessions.py", line 528, in patch
    return self.request('PATCH', url,  data=data, **kwargs)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests/sessions.py", line 465, in request
    resp = self.send(prep, **send_kwargs)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests/sessions.py", line 573, in send
    r = adapter.send(request, **kwargs)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests/adapters.py", line 431, in send
    raise SSLError(e, request=request)
SSLError: Can't connect to HTTPS URL because the SSL module is not available.
Unknown Error: Can't connect to HTTPS URL because the SSL module is not available.
Exiting with 1

===============================================================================
=                                                                             =
=  __  __                ____    ___              _          _  _             =
= |  \\/  |  __ _  _ __  |  _ \\  |_ _| _ __   ___ | |_  __ _ | || |  ___  _ __ =
= | |\\/| | / _` || '_ \\ | |_) |  | | | '_ \\ / __|| __|/ _` || || | / _ \\| '__|=
= | |  | || (_| || |_) ||  _ <   | | | | | |\\__ \\| |_| (_| || || ||  __/| |   =
= |_|  |_| \\__,_|| .__/ |_| \\_\\ |___||_| |_||___/ \\__|\\__,_||_||_| \\___||_|   =
=                |_|                                                          =
=                                                                             =
===============================================================================
Version: 5.0.0.ui1.1.83

python script exited with 1

2015-11-09 13:23:13.120:
2015-11-09 13:24:25.369:

Outcomes