AnsweredAssumed Answered

/oozie/share/lib Missing and Cluster Failed to Initialize

Question asked by zayd on Oct 22, 2015
Latest reply on Oct 23, 2015 by zayd
I am currently running on a MapR VM based cluster with Oozie 4.1.0 and hadoop 2.5.1.  Note the cluster uses yarn.  I wrote a map reduce program that runs without issue when I call "hadoop jar ...".  However, when I try to run the map reduce jar from Oozie, I get an error that /opt/share/lib is missing as shown below:


    org.apache.oozie.action.ActionExecutorException: File /oozie/share/lib does not exist
            at     org.apache.oozie.action.hadoop.JavaActionExecutor.addSystemShareLibForAction(JavaActionExecutor.java:620)
    .........
What looked like the most promising solution was to then copy the folder "share2" from /opt/mapr/oozie/oozie-4.1.0/ to that directory structure.   My first question is whether that step is correct as I could not find others who had a similar issue.

Once I do that, I then try to run my job and get the error below:

    org.apache.oozie.action.ActionExecutorException: JA009: Cannot initialize Cluster. Please check your configuration for mapreduce.framework.name and the correspond server addresses.
            at org.apache.oozie.action.ActionExecutor.convertExceptionHelper(ActionExecutor.java:412)
    ..........
Below is my job.properties file:

    nameNode=maprfs:///
    jobTracker=localhost:8032
    queueName=default
    examplesRoot=examples
    oozie.wf.application.path=/user/user01/lab2/exercise4/zayd_hammoudeh_lab2_exercise4/workflow.xml

For the job tracker, I tried "maprfs:///" and "*cluster-name*:8032" (where "cluster-name" corresponds to my VM's name e.g. "mapr1node"), and all give the same error.  I can add my workflow file it is helpful.  I have spent a few days trying to debug this so any guidance I would really appreciate.











Outcomes