AnsweredAssumed Answered

Error installing MapR Hive ODBC driver for CentOS 7

Question asked by jdhok on Oct 8, 2015
I downloaded the rpm for MapR Hive ODBC  from http://package.mapr.com/tools/MapR-ODBC/MapR_Hive/MapRHive_odbc_2.1.8.1005/Linux/EL6/MapRHiveODBC-2.1.8.1005-1.el6.x86_64.rpm

When I try to install the package on CentOS 7, I get the following error -

    # rpm -ivh MapRHiveODBC-2.1.8.1005-1.el6.x86_64.rpm
    error: Failed dependencies:
     libsasl2.so.2()(64bit) is needed by MapRHiveODBC-2.1.8.1005-1.x86_64

Please advise where/how to get the Hive ODBC driver for CentOS 7.

Edit:
I tried symlinking libsasl2.so.2 to libsasl2.so.3, but that doesn't work either.

Outcomes