AnsweredAssumed Answered

Reducer set to 1 even when i set to 200

Question asked by yeeee on Aug 8, 2015
I am running an sql script with hive. I want to increase the number of reducers for a certain job. I don't think that is possible so I tried setting the number of reducers for all jobs to 200. When I did this only the first job had 200 reducers then the next one 1 reducer. How can I fix this to have all of them having 200 reducers?

I tried doing this set mapred.reduce.tasks=200

Outcomes