AnsweredAssumed Answered

MapR HBase with Java 8

Question asked by tc_dev on Jul 7, 2015
Latest reply on Jul 9, 2015 by akrd
We are exploring Java 8 migration to benefit from new software that now requires it.

According to MapR docs ( http://doc.mapr.com/display/MapR/JDK+Support+Matrix ) Java 8 is supported for 4.x however the status of ecosystem components is unclear. In our case we care about HBase.

Now according to the official HBase book Java 8 is "not well tested" for 0.98 and they are reporting several open issues including failures in some unit tests: http://hbase.apache.org/book.html#java

My question is whether MapR's ecosystem distribution of HBase has been tested with Java 8 as well as MapR core... If it is not yet supported, when are you planning to.

Outcomes