AnsweredAssumed Answered

M7 table column level security

Question asked by mayur_saparia on May 20, 2015
Latest reply on May 21, 2015 by mayur_saparia
Hello everyone,
I have been trying to set up column level security to m7 tables, I am using sandbox just to test how its working.
I am using hbase shell to create table and then after creating the tables , I have created a new user and then switched to that user and then I start the hbase shell and then tried to lookup the table, but since I din't had permission for that user it throws me an exception (This is what i expected , with out the permission for the user). But after that I switched back to root user and then gave the user permission to read the table's column family and particular column with the following command.

    maprcli table cf colperm set -path /mytable -cfname cf1 -name col1 -readperm 'g:group1'

it executed and then I switched back to the previous user and then tried to view the rows from Hbase table. (Expected behavior was showing the rows for the given column family name and cloumn) but to my surprise it returned me 0 rows. I dont get any errors, no clues nothing. I am clueless on how to solve this problem. I even tried using MCS to set ther permission to the user, but that didn't even work to. One thing which I came across was when i set permission to the user from terminal it should be reflected in Terminal Ideally (Correct me if wrong), but thats not the case.

Experts please pour in your suggestion let me know how to handle column level security for m7 tables.

Outcomes