AnsweredAssumed Answered

Cannot start mapr-installer

Question asked by ykk on May 29, 2015
Latest reply on Sep 23, 2015 by ashtuoshsharmaindia
After I executed mapr-setup.sh under ubuntu 15.04, I got the following messages and I cannot start mapr-installer:

-----------------------------------------------------------------------------------------------------------------------------------------
Installing package dependencies...

Reading package lists...
Building dependency tree...
Reading state information...
libssl1.0.0 is already the newest version.
openssh-client is already the newest version.
python-pycurl is already the newest version.
sudo is already the newest version.
wget is already the newest version.
sshpass is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

...Success


Testing for JDK 7 or 8...

...Success


Testing connection to http://package.mapr.com/releases...

...Success

Installing packages...

Ign http://archive.mapr.com binary/ InRelease
Ign http://package.mapr.com binary/ InRelease
Ign http://ppa.launchpad.net vivid InRelease
Hit http://archive.mapr.com mapr InRelease
Hit http://ppa.launchpad.net vivid Release.gpg
Ign http://archive.mapr.com binary/ Release.gpg
Ign http://package.mapr.com binary/ Release.gpg
Hit http://ppa.launchpad.net vivid Release
Hit http://archive.mapr.com mapr/optional amd64 Packages
Hit http://ppa.launchpad.net vivid/main amd64 Packages
Ign http://package.mapr.com binary/ Release
Get:1 http://package.mapr.com binary/ Packages [697 B]
Hit http://ppa.launchpad.net vivid/main Translation-en
Ign http://archive.mapr.com binary/ Release
Ign http://archive.mapr.com binary/ Packages/DiffIndex
Ign http://package.mapr.com binary/ Translation-en_US
Hit http://archive.mapr.com binary/ Packages
Ign http://package.mapr.com binary/ Translation-en
Ign http://archive.mapr.com mapr/optional Translation-en_US
Ign http://archive.mapr.com mapr/optional Translation-en
Ign http://archive.mapr.com binary/ Translation-en_US
Ign http://archive.mapr.com binary/ Translation-en
Fetched 697 B in 6s (105 B/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
mapr-installer-definitions is already the newest version.
mapr-installer is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

...Success

Failed to restart mapr-installer.service: Unit mapr-installer.service failed to load: No such file or directory.

ERROR: mapr-installer startup failed:

--------------------------------------------------------------------------------------------------------------------------------------------

I tried running "service" command to start mapr-installer but failed...

$service mapr-installer start

Failed to start mapr-installer.service: Unit mapr-installer.service failed to load: No such file or directory.

I can finally start the mapr-installer by "/etc/init.d/mapr-installer start" and go further to the quick installation. However, I got the same problem (Failed to restart mapr-installer.service: Unit mapr-zookeeper.service failed to load: No such file or directory.) when starting the mapr-zookeeper.

May I know where is problem and how can I fix that? Thanks very much.



Outcomes