AnsweredAssumed Answered

Jackson error in elasticsearch hadoop while loading data to elasticsearch in Mapr distribution

Question asked by sibbsnb on Apr 20, 2015
Has anyone in Mapr community experienced the below:

https://github.com/elastic/elasticsearch-hadoop/issues/425

I am trying to load data from hdfs to elasticsearch using elasticsearch-hadoop version elasticsearch-hadoop-2.1.0.Beta3.jar.

There was a bug on Mapr #215 which was supposed to fix the jackson issue. But it is still taking the jackson jars from the hadoop directory which has jackson version 1.5.

I did register commands to the 1.8 jars: REGISTER /opt/mapr/hive/hive/lib/jackson-core-asl-1.8.8.jar; REGISTER /opt/mapr/hive/hive/lib/jackson-jaxrs-1.8.8.jar; REGISTER /opt/mapr/hive/hive/lib/jackson-mapper-asl-1.8.8.jar; REGISTER /opt/mapr/hive/hive/lib/jackson-xc-1.8.8.jar;

But i am still getting the error i am getting:
2015-04-17 05:49:03,760 [main] ERROR org.apache.pig.tools.pigstats.SimplePigStats - ERROR 2997: Unable to recreate exception from backed error: Error: org.codehaus.jackson.map.ObjectMapper.reader(Ljava/lang/Class;)Lorg/codehaus/jackson/map/ObjectReader;

i tried the same with Hive and getting the same error as well.

Outcomes