AnsweredAssumed Answered

Mapr Installation on Single Node cluster

Question asked by shashi.vish on Apr 9, 2015
Latest reply on Apr 16, 2015 by shashi.vish
Hi,

I am trying to set up a single node cluster on a Cent OS machine but installation failed in between with error saying that failed to format for MapR FS . Here is a log for the same.


    false, "type": "ether"}, "module_setup": true}, "changed": false, "verbose_override": true}
    2015-04-09 18:43:47,164 callbacks 42 [INFO]: Running task: [stat path="{{ diskfile }}"]
    2015-04-09 18:43:47,164 callbacks 113 [INFO]: ok: [masterNode] => {"changed": false, "stat": {"exists": false}}
    2015-04-09 18:43:47,671 callbacks 42 [INFO]: Running task: [stat path="{{ diskfile }}"]
    2015-04-09 18:43:47,672 callbacks 113 [INFO]: ok: [masterNode] => {"changed": false, "stat": {"exists": false}}
    2015-04-09 18:43:48,175 callbacks 42 [INFO]: Running task: [lineinfile dest="{{ diskfile }}" create=yes mode=0644 regexp="{{ item }}" line="{{ item }}"]
    2015-04-09 18:43:48,176 callbacks 113 [INFO]: changed: [masterNode] => (item=/dev/sda2) => {"backup": "", "changed": true, "item": "/dev/sda2", "msg": "line added"}
    2015-04-09 18:43:48,676 callbacks 42 [INFO]: Running task: [stat path="{{ diskfile }}"]
    2015-04-09 18:43:48,677 callbacks 113 [INFO]: ok: [masterNode] => {"changed": false, "stat": {"atime": 1428585228.164226, "ctime": 1428585228.164226, "dev": 64768, "exists": true, "gid": 0, "inode": 1972483, "isblk": false, "ischr": false, "isdir": false, "isfifo": false, "isgid": false, "islnk": false, "isreg": true, "issock": false, "isuid": false, "md5": "5b66161af84f8f6ac3fd2a9ee62de3a5", "mode": "0644", "mtime": 1428585228.164226, "nlink": 1, "pw_name": "root", "rgrp": true, "roth": true, "rusr": true, "size": 10, "uid": 0, "wgrp": false, "woth": false, "wusr": true, "xgrp": false, "xoth": false, "xusr": false}}
    2015-04-09 18:43:49,174 callbacks 42 [INFO]: Running task: [stat path="{{ disktab }}"]
    2015-04-09 18:43:49,174 callbacks 113 [INFO]: ok: [masterNode] => {"changed": false, "stat": {"exists": false}}
    2015-04-09 18:43:51,919 callbacks 42 [INFO]: Running task: [do_disksetup.sh MAPR_HOME={{ mapr_home }} DISKFILE={{ diskfile }} STRIPE_WIDTH={{ diskstripe }} FORCE_FORMAT={{ force_format }}]
    2015-04-09 18:43:51,920 callbacks 78 [INFO]: failed: [masterNode] => {"failed": true}
    2015-04-09 18:43:51,921 callbacks 79 [INFO]: masterNode: ...ignoring errors
    2015-04-09 18:43:52,432 callbacks 42 [INFO]: Running task: [shell rm -f {{ diskfile }}]
    2015-04-09 18:43:52,434 callbacks 113 [INFO]: changed: [masterNode] => {"changed": true, "cmd": "rm -f /opt/mapr/conf/disks.txt", "delta": "0:00:00.003031", "end": "2015-04-09 18:43:52.418168", "rc": 0, "start": "2015-04-09 18:43:52.415137", "stderr": "", "stdout": ""}
    2015-04-09 18:43:52,446 callbacks 42 [INFO]: Running task: [fail msg="Failed to format {{ mapr.node.disks|join(',') }} for MapR FS.  Check {{ mapr_home }}/logs/disksetup.0.log.  Please re-run the installer after addressing the reported issue(s)."]
    2015-04-09 18:43:52,447 callbacks 87 [ERROR]: masterNode: **Failed to format /dev/sda2** for MapR FS.  Check /opt/mapr/logs/disksetup.0.log.  Please re-run the installer after addressing the reported issue(s).
    2015-04-09 18:43:52,447 callbacks 91 [ERROR]: failed: [masterNode] => {"failed": true}
    2015-04-09 18:43:52,447 installrunner 199 [ERROR]: Host: masterNode has 1 failures
    2015-04-09 18:43:52,447 common 203 [ERROR]: Control Nodes have failures. Please fix the failures and re-run the installation. For more information refer to the installer log at /opt/mapr-installer/var/mapr-installer.log

I read other questions on forum those who were facing same issue , from that i could understand that MapR is expecting separate disk on which MapR FS will be installed. I believe that as i have currently one disk in my machine because of that it might be causing issue. I just did lsblk on my machine and here is an output for the same.

    NAME                             MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT

    sda                                8:0    0 465.8G  0 disk

    â”œâ”€sda1                             8:1    0   500M  0 part /boot

    â””─sda2                             8:2    0 465.3G  0 part

         â”œâ”€vg_bigdatacoe-lv_root (dm-0) 253:0    0    50G  0 lvm  /

         â”œâ”€vg_bigdatacoe-lv_swap (dm-1) 253:1    0   7.7G  0 lvm  [SWAP]

        â””─vg_bigdatacoe-lv_home (dm-2) 253:2    0 407.6G  0 lvm  /home

    sr0                               11:0    1  1024M  0 rom
 
Kindly let me know how should i proceed here.

Thanks in advance.
Shashi

Outcomes