AnsweredAssumed Answered

Apt cannot install hbase-internal package

Question asked by p3r3 on Jan 23, 2015
Latest reply on Jan 24, 2015 by uffe
While deploying a new M3 cluster today I noticed that I can no longer install the mapr-hbase-internal package due to a file conflict with mapr-hbase. I am assuming something was changed on the deb servers as the exact same commands worked on monday of this week. It seems to force install mapr-hbase which I do not remember from monday. Below is the output of the apt command:

    ubuntu@mapr-02:~$ sudo apt-get install -f mapr-hbase-internal
        Reading package lists... Done
        Building dependency tree      
        Reading state information... Done
        The following extra packages will be installed:
          mapr-hbase
        The following NEW packages will be installed:
          mapr-hbase mapr-hbase-internal
        0 upgraded, 2 newly installed, 0 to remove and 82 not upgraded.
        Need to get 0 B/78.8 MB of archives.
        After this operation, 0 B of additional disk space will be used.
        Do you want to continue? [Y/n] y
        WARNING: The following packages cannot be authenticated!
          mapr-hbase mapr-hbase-internal
        Install these packages without verification? [y/N] y
        Selecting previously unselected package mapr-hbase.
        (Reading database ... 72123 files and directories currently installed.)
        Preparing to unpack .../mapr-hbase_0.98.7.201501131825_all.deb ...
        Unpacking mapr-hbase (0.98.7.201501131825) ...
        Preparing to unpack .../mapr-hbase-internal_0.98.7.201501131825_all.deb ...
        mapr-hbase-internal preinstall
        Unpacking mapr-hbase-internal (0.98.7.201501131825) ...
        dpkg: error processing archive /var/cache/apt/archives/mapr-hbase-internal_0.98.7.201501131825_all.deb (--unpack):
         trying to overwrite '/opt/mapr/roles/hbinternal', which is also in package mapr-hbase 0.98.7.201501131825
        mapr-hbase-internal post remove
        Errors were encountered while processing:
         /var/cache/apt/archives/mapr-hbase-internal_0.98.7.201501131825_all.deb
        E: Sub-process /usr/bin/dpkg returned an error code (1)
    
Here is my apt source:

    deb http://package.mapr.com/releases/v4.0.1/ubuntu mapr optional
    deb http://package.mapr.com/releases/ecosystem-4.x/ubuntu binary/




Outcomes