AnsweredAssumed Answered

mapr-core -v3.1.1 GA fialed to installed

Question asked by pratap20 on Jan 11, 2015
Latest reply on Jan 12, 2015 by nabeel
I have four node MapR-cluster  running fine . but I want to add one more node to the cluster.I have checked & performed all prerequisites before installing mapr packages . I have downloaded mapr packages  & extract it . But when I tried to run rpm -ivh mapr-core-v3.1.1 GA  It stops with  below error msgs.


     
     file /opt/mapr/hadoop/hadoop-0.20.2/lib/junit-4.5.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/kfs-0.2.2.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/kfs-0.2.LICENSE.txt from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/mockito-all-1.8.5.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/oro-2.0.8.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/servlet-api-2.5-20081211.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/servlet-api-2.5-6.1.14.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/lib/xmlenc-0.52.jar from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/mapr-hadoop-patches.txt from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/libhdfs/hdfs.h from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/libhdfs/hdfs_read.c from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/libhdfs/hdfs_test.c from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/libhdfs/hdfs_write.c from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/.autom4te.cfg from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/.autom4te.cfg from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/.autom4te.cfg from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/Makefile.am from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/Makefile.am from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/Makefile.am from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/Makefile.in from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/Makefile.in from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/Makefile.in from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/aclocal.m4 from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/aclocal.m4 from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/aclocal.m4 from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/conf/word-part.xml from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/conf/word.xml from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/config.guess from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/config.guess from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/config.guess from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/config.sub from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/config.sub from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/config.sub from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/configure from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/configure from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/configure from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/configure.ac from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/configure.ac from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/configure.ac from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/depcomp from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/depcomp from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/depcomp from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/impl/config.h.in from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/impl/config.h.in from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/impl/config.h.in from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/impl/sort.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/impl/wordcount-nopipe.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/impl/wordcount-part.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/impl/wordcount-simple.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/install-sh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/install-sh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/install-sh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/ltmain.sh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/ltmain.sh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/ltmain.sh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes-example/missing from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/missing from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/missing from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/api/hadoop/Pipes.hh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/api/hadoop/TemplateFactory.hh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/compile from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/debug/pipes-default-gdb-commands.txt from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/debug/pipes-default-script from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/pipes/impl/HadoopPipes.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/api/hadoop/SerialUtils.hh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/api/hadoop/StringUtils.hh from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/impl/SerialUtils.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/impl/StringUtils.cc from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/src/c++/utils/m4/hadoop_utils.m4 from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/webapps/static/hadoop-logo.jpg from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/webapps/static/jobconf.xsl from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/webapps/static/jobtracker.js from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64
      file /opt/mapr/hadoop/hadoop-0.20.2/webapps/static/sorttable.js from install of mapr-core-3.0.3.25439.GA-1.x86_64 conflicts with file from package mapr-mapreduce1-0.20.2.27334.GA-1.x86_64

Error Summary
-------------

although I tried to find above mebtioned file but not exist. Please help me resolve this issue .Thanks in advance.


Outcomes