AnsweredAssumed Answered

Problem with Quick Installer on Amazon Instances... [wait_for_zk_service.sh max_wait=600 zk_nodes={{mapr.groups.zk|join(',')}}]

Question asked by xxxantikvarxxx on Dec 22, 2014
Latest reply on Feb 20, 2015 by leonclayton
Hello guys!

Maybe you can help me, because I don't found answer for my question in documentation and google (((

<p>I have 5 Amazon Instance for my Cluster:</p>
<p>1 Control Node</p>
<p>3 Data Node</p>
<p>1 Client Node</p>
Here is a configuration file that I use for Quick Installer
##########################################################################
<p>[Control_Nodes]</p>
<p>ip-172-31-7-1.us-west-2.compute.internal: /dev/xvdb, /dev/xvdc</p>
<p>[Data_Nodes]</p>
<p>ip-172-31-6-2.us-west-2.compute.internal: /dev/xvdb, /dev/xvdc</p>
<p>ip-172-31-6-3.us-west-2.compute.internal: /dev/xvdb, /dev/xvdc</p>
<p>ip-172-31-6-4.us-west-2.compute.internal: /dev/xvdb, /dev/xvdc</p>
<p>[Client_Nodes]</p>
<p>ip-172-31-6-5.us-west-2.compute.internal</p>
<p>[Options]</p>
<p>MapReduce1 = true</p>
<p>YARN = true</p>
<p>HBase = false</p>
<p>MapR-DB = true</p>
<p>ControlNodesAsDataNodes = false</p>
<p>WirelevelSecurity = false</p>
<p>LocalRepo = false</p>
<p>[Defaults]</p>
<p>ClusterName = mapr.cluster.com</p>
<p>User = mapr</p>
<p>Group = mapr</p>
<p>Password = ***************</p>
<p>UID = 2000</p>
<p>GID = 2000</p>
<p>Disks = /dev/xvdb, /dev/xvdc</p>
<p>StripeWidth = 3</p>
<p>ForceFormat = true</p>
<p>CoreRepoURL = http://package.mapr.com/releases</p>
<p>EcoRepoURL = http://package.mapr.com/releases/ecosystem</p>
<p>Version = 4.0.0-FCS</p>
<p>MetricsDBHost =</p>
<p>MetricsDBUser =</p>
<p>MetricsDBPassword =</p>
<p>MetricsDBSchema =</p>
##########################################################################

I was start Quick Installer with next params: sudo bash /opt/mapr-installer/bin/install --cfg /opt/mapr-installer/bin/config.test --private-key /home/ubuntu/.ssh/key.pem -u ubuntu -s -U root -K new

Quick Installer was very well installing and starting MapR services on Control Node, but when was started installing on Data Node - the installation process hangs at startup MapR services

When i started Quick Installer with parametr --debug. I saw what process hangs when starting this task

TASK: [wait_for_zk_service.sh max_wait=600 zk_nodes={{mapr.groups.zk|join(',')}}]

And I don't understand why this process hangs, maybe you can help me with this problem?

OS: Ubuntu x86_64

Outcomes