AnsweredAssumed Answered

storm service show running but no logs or ui

Question asked by plcurran on Dec 16, 2014
Latest reply on Dec 16, 2014 by plcurran
I have setup storm on one node of M3  4.0.1 five node Cluster but it kept failing so I removed and set it up again on another master node. It too now show services as running and then failing after maybe 5 min on this node also. I am trying to troubleshoot but the logs directory is empty. I have tried to uninstall and reinstall using yum but still no logs. The path is displayed on the mapr webserver when I check node next to the storm service listed but location is empty when I check it.
I was expecting to see nimbus.log etc
/opt/mapr/storm/storm-0.9.3/logs
[root@xxxxxxx logs]# ls
[root@xxxxxxx logs]# ls -l
total 0
[root@xxxxxx logs]#

Please can someone help with a possible reason or is there a way to do fresh install after removing storm with yum. I noticed after yum removal it leaves the storm-0.9.3 folder with just conf in it. should I remove that too first before reinstall.

Thank you

Paul.

Outcomes