AnsweredAssumed Answered

Upgrade from 4.0 FCS to 4.0.1 - Java Unsupported major.minor version 51.0

Question asked by mandoskippy on Nov 18, 2014
Latest reply on Nov 18, 2014 by mava
I had been running well on MapR 4.0 FCS. I did an offline upgrade to 4.0.1, and when I go to start the warden on the cldb I get a failure and my warden.log is below.  I am running openjdk 6 (which wasn't an issue on 4.0FCS).  I didn't change the java, however I did run apt-get upgrade, so it may have grabbed a newer version. 

java -version
java version "1.6.0_33"
OpenJDK Runtime Environment (IcedTea6 1.13.5) (6b33-1.13.5-1ubuntu0.12.04)
OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)



warden.log

chown: cannot access `/opt/mapr/hadoop/hadoop-2.4.1/logs/*': No such file or directory
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/mapr/warden/WardenMain : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: com.mapr.warden.WardenMain. Program will exit.
/etc/init.d/mapr-warden: line 226: kill: (2753) - No such process
Warden start failed
Error: warden can not be started. See /opt/mapr/logs/warden.log for details

Outcomes