AnsweredAssumed Answered

renice setting in /etc/security/limits.conf on RHEL/CENTOS 6.X

Question asked by dxbarnes on Sep 19, 2014
Latest reply on Sep 22, 2014 by mava
I have a situation were MAPR is insistent on putting a line in the limits.conf file:

mapr - renice -10

Furthermore, MAPR support is insistent that it is VALID.

This is not a valid ulimits setting.  Whomever at MAPR made the decision to put this into the limits.conf file needs to go back and re-read the man page for ulimit to get a better understanding of them.

If you want to validate that it is NOT a valid setting, simply put it into your limits.conf file for a particular user, log in as that user, and then check your /var/log/secure file and you will see the following:

Sep 19 09:21:48 <server_name_removed> su: pam_limits(su-l:session): unknown limit item 'renice'

The limit for limiting what a user can renice a process to is controlled only the the "nice" setting in limits.conf.

PLEASE PLEASE PLEASE get a better understanding of ulimits and fix this in your product offering.

Outcomes