AnsweredAssumed Answered

Correct sudo user for Ubuntu Quick Install

Question asked by jbarnett on Jul 29, 2014
Latest reply on Jul 30, 2014 by jbarnett
I have tried a few different combiations of sudo user and user for the quick install on Ubuntu 12.04. I keep running into permission issues where it looks like it is not properly sudo'ing to root. I have tried both ubuntu and root for the --sudo-user parameter.

 - This is on AWS EC2, and I have also tried both the internal and external DNS names for the servers.
 - I can ssh with the key file to the other machines.

TXS!

**ubuntu@ip-10-159-12-103:~$ sudo /opt/mapr-installer/bin/install -u ubuntu -s --sudo-user ubuntu -U ubuntu --private-key /home/ubuntu/mykey.pem --skip-checks new**

Verifying install pre-requisites
... verified
...
Version: 2.0.163

A cluster configuration was found, do you wish to use this configuration? Choosing 'n' allows you to start a fresh installation and will overwrite the previous configuration. (y/n) [n]: n

An Installer config file is typically used by experienced MapR admins to skip thorough the interview process.

Do you have a config file (y/n) [n]: n
Enter the hostnames of all the control nodes separated by spaces or commas []: ip-10-159-12-103.ec2.internal
Enter the hostnames of all the data nodes separated by spaces or commas []: ip-10-159-12-103.ec2.internal,ip-10-230-12-101.ec2.internal,ip-10-230-12-94.ec2.internal
Set MapR User Name [mapr]: mapr
Set MapR User Password [mapr]:
Is this cluster going to run MapReduce? (y/n) [y]: y
Is this cluster going to run Apache HBase? (y/n) [n]: y
Is this cluster going to run MapR M7? (y/n) [n]: y
Enter the full path of disks for hosts separated by spaces or commas []: /mnt2/sdb

        Current Information (Please verify if correct)
        ==============================================

        Accessibility settings:

            Cluster Name: "my.cluster.com"
            MapR User Name: "mapr"
            MapR Group Name: "mapr"
            MapR User UID: "2000"
            MapR User GID: "2000"
            MapR User Password (Default: mapr): "****"

        Functional settings:

            WireLevel Security: "n"
            MapReduce Services: "y"
            MapR M7: "y"

            HBase: "n"
            Disks to use: "/mnt2/sdb"
            Client Nodes: ""
            Control Nodes: "ip-10-159-12-103.ec2.internal"
            Data Nodes: "ip-10-230-12-101.ec2.internal,ip-10-230-12-94.ec2.internal"
            Repository (will download core software from here): "http://package.mapr.com/releases"
            Ecosystem Repository (will download packages like Pig, Hive etc from here): "http://package.mapr.com/releases/ecosystem"

            MapR Version to Install: "3.1.1"
            Java Version to Install: "OpenJDK7"
            Allow Control Nodes to function as Data Nodes (Not recommended for large clusters): "n"
            Local Repository: "n"

        Metrics settings:

            Metrics DB Host and Port: ""
            Metrics DB User Name: ""
            Metrics DB User Password: ""
            Metrics DB Schema: ""

        
(c)ontinue with install, (m)odify options, or save current configuration and (a)bort? (c/m/a) [c]: c
Now running on Control Nodes: [ip-10-159-12-103.ec2.internal]
* 23:26:38 Interrogating Node(s), Validating Prerequisites, and Starting Install
* 23:26:41 Installing Extra Package Repositories If Needed
* 23:26:43 Detecting Operating System
* 23:26:46 Installing Prerequisite Packages for Ubuntu/Debian
* 23:26:53 Detecting Operating System
fatal: [ip-10-159-12-103.ec2.internal] => failed to parse: Traceback (most recent call last):
  File "/tmp/ansible-tmp-1406676416.41-98124502486653/lineinfile", line 1576, in <module>
    main()
  File "/tmp/ansible-tmp-1406676416.41-98124502486653/lineinfile", line 361, in main
    ins_aft, ins_bef, create, backup, backrefs)
  File "/tmp/ansible-tmp-1406676416.41-98124502486653/lineinfile", line 270, in present
    write_changes(module, lines, dest)
  File "/tmp/ansible-tmp-1406676416.41-98124502486653/lineinfile", line 165, in write_changes
    module.atomic_move(tmpfile, dest)
  File "/tmp/ansible-tmp-1406676416.41-98124502486653/lineinfile", line 1403, in atomic_move
    prefix=".ansible_tmp", dir=dest_dir, suffix=dest_file)
  File "/usr/lib/python2.7/tempfile.py", line 454, in NamedTemporaryFile
    (fd, name) = _mkstemp_inner(dir, prefix, suffix, flags)
  File "/usr/lib/python2.7/tempfile.py", line 235, in _mkstemp_inner
    fd = _os.open(file, flags, 0600)
OSError: [Errno 13] Permission denied: '/etc/ssh/.ansible_tmpcxpODBsshd_config'


FATAL: all hosts have already failed -- aborting
Host: ip-10-159-12-103.ec2.internal is unreachable
Control Nodes have failures. Please fix the failures and re-run the installation.

Outcomes