AnsweredAssumed Answered

Oozie Error : HTTP error code: 500 : Internal Server Error

Question asked by edjatsa on Jun 3, 2014
Latest reply on Jun 16, 2014 by nabeel
Hello, 
I'm getting error message HTTP error code: 500 : Internal Server Error when submitting the examples packaged in oozie.

I submit the example job with :
<code>

oozie job --oozie http://<oozie_web_url> -config job.properties -run
</code>

Then I get the "500 : Internal Server Error " . No job is created, I can't see any new entry in the Oozie web console.

In the oozie.log file I get the following logs :
<pre>
2014-06-03 15:01:53,358  WARN AuthenticationFilter:375 - AuthenticationToken ignored: AuthenticationToken expired 
2014-06-03 15:01:53,525  WARN AuthenticationFilter:375 - AuthenticationToken ignored: AuthenticationToken expired 
2014-06-03 15:01:53,525  WARN AuthenticationFilter:375 - AuthenticationToken ignored: AuthenticationToken expired 
2014-06-03 15:01:53,540 DEBUG UserGroupInformation:409 - Found no authentication principals in subject. Simple? 
2014-06-03 15:01:53,540 DEBUG FileSystem:1517 - Creating filesystem for maprfs:/user/<username>/oozie/examples/apps/map-reduce 
2014-06-03 15:01:53,541 DEBUG UserGroupInformation:409 - Found no authentication principals in subject. Simple? 
2014-06-03 15:02:13,132  INFO StatusTransitService$StatusTransitRunnable:539 - USER[-] GROUP[-] Acquired lock for [org.apache.oozie.service.StatusTransitService] 
</pre>
............

Job configuration (job.properties ):
<code>
jobTracker=maprfs:/// 
nameNode=maprfs:///
</code>

Here is my cluster configuration :

 - Mapr V3.1  
 - Oozie 4.0.0

 - security and authentication settings in oozie/conf/oozie-site.xml     
<pre>
     < property> 
            <name>oozie.service.AuthorizationService.security.enabled</name>
            <value>false</value>
            <description>
                Specifies whether security (user name/admin role) is enabled or not.
                If disabled any user can manage Oozie system and manage any job.
            </description>   </property> 
         <property>
            <name>oozie.authentication.type</name>
            <value>simple</value>
            <description>
                Defines authentication used for Oozie HTTP endpoint.
                Supported values are: simple | kerberos |
                ###  AUTHENTICATION\_HANDLER\_CLASSNAME  ###
            </description>
        </property>   <property>
          <name>oozie.service.ProxyUserService.proxyuser.mapr.hosts</name>
          <value>*</value>
        </property>
        <property>
          <name>oozie.service.ProxyUserService.proxyuser.mapr.groups</name>
          <value>*</value>
        </property>
        <property>
            <name>oozie.service.HadoopAccessorService.kerberos.enabled</name>
            <value>${mapr_sec_enabled}</value>
            <description>
                Indicates if Oozie is configured to use Kerberos.
            </description>
        </property>
        <property>
            <name>oozie.service.HadoopAccessorService.hadoop.configurations</name>
            <value>*=${hadoop_conf_directory}</value>
            <description>
                Comma separated AUTHORITY=HADOOP_CONF_DIR, where AUTHORITY is the HOST:PORT of the Hadoop service (JobTracker, HDFS). The wildcard '*' configuration is used when there is no exact match for an authority. The HADOOP_CONF_DIR contains the relevant Hadoop *-site.xml files. If the path is relative is looked within the Oozie configuration directory; though the path can be absolute (i.e. to point to Hadoop client conf/ directories in the local filesystem.
            </description>
        </property>
</pre>

Could you please help me to solve this issue ?
Thanks and regards,
Eric

Outcomes