AnsweredAssumed Answered

MapReduce Job Only Uses One Core

Question asked by communityadmin on Mar 20, 2014
I'm trying to run a MapReduce job on MapR on a two-node cluster.  It's a streaming job using the python word count examples.  The job runs fine, but it's only using a single core when I have 16 available. 

Is there any way to tell MapR to use all cores, or to increase the number of cores being used?

I am using these options in my streaming job:
-D mapred.reduce.tasks=4
-D mapred.map.tasks=8

Thank you.

Outcomes