AnsweredAssumed Answered

MapR Metrics service dependent package (java-gcj-compat) not getting installed.

Question asked by jatin on Jan 9, 2014
Latest reply on Jan 13, 2014 by nabeel
**I was trying to install the MapR Metrics service on a RHEL 6.2 (64-bit)Node when I got stuck with some package not found issues. The yum output is as follows:**
<code>
</media/RHEL_6.2 x86_64 Disc 1/Packages>yum install mapr-metrics
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mapr-metrics.x86_64 0:3.0.2.22510.GA-1 will be installed
--> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics-3.0.2.22510.GA-1.x86_64
--> Processing Dependency: soci-mysql for package: mapr-metrics-3.0.2.22510.GA-1.x86_64
--> Running transaction check
---> Package mapr-metrics.x86_64 0:3.0.2.22510.GA-1 will be installed
--> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics-3.0.2.22510.GA-1.x86_64
---> Package soci-mysql.x86_64 0:3.2.1-1.el6 will be installed
--> Processing Dependency: soci(x86-64) = 3.2.1-1.el6 for package: soci-mysql-3.2.1-1.el6.x86_64
--> Processing Dependency: libsoci_core.so.3.2()(64bit) for package: soci-mysql-3.2.1-1.el6.x86_64
--> Running transaction check
---> Package mapr-metrics.x86_64 0:3.0.2.22510.GA-1 will be installed
--> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics-3.0.2.22510.GA-1.x86_64
---> Package soci.x86_64 0:3.2.1-1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: mapr-metrics-3.0.2.22510.GA-1.x86_64 (maprtech)
           Requires: mysql-connector-java >= 5.1.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
</media/RHEL_6.2 x86_64 Disc 1/Packages>yum install  mysql-connector-java-5.1.12-2.el6.x86_64.rpm
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Setting up Install Process
Examining mysql-connector-java-5.1.12-2.el6.x86_64.rpm: 1:mysql-connector-java-5.1.12-2.el6.x86_64
Marking mysql-connector-java-5.1.12-2.el6.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package mysql-connector-java.x86_64 1:5.1.12-2.el6 will be installed
--> Processing Dependency: java-gcj-compat >= 1.0.31 for package: 1:mysql-connector-java-5.1.12-2.el6.x86_64
--> Processing Dependency: java-gcj-compat >= 1.0.31 for package: 1:mysql-connector-java-5.1.12-2.el6.x86_64
--> Processing Dependency: jta >= 1.0 for package: 1:mysql-connector-java-5.1.12-2.el6.x86_64
--> Processing Dependency: log4j for package: 1:mysql-connector-java-5.1.12-2.el6.x86_64
--> Finished Dependency Resolution
Error: Package: 1:mysql-connector-java-5.1.12-2.el6.x86_64 (/mysql-connector-java-5.1.12-2.el6.x86_64)
           Requires: java-gcj-compat >= 1.0.31
Error: Package: 1:mysql-connector-java-5.1.12-2.el6.x86_64 (/mysql-connector-java-5.1.12-2.el6.x86_64)
           Requires: log4j
Error: Package: 1:mysql-connector-java-5.1.12-2.el6.x86_64 (/mysql-connector-java-5.1.12-2.el6.x86_64)
           Requires: jta >= 1.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

</code>
**The following package "java-gcj-compat" is nowhere to be found in the Package repository for RHEL. Can somebody give me pointers on how to solve this issue.**

Outcomes