AnsweredAssumed Answered

Oozie build failure ( release-3.3.0-mapr version )

Question asked by giridhar on Oct 24, 2013
Latest reply on Oct 28, 2013 by nabeel
We are using RedHat distribution of Linux

We are using 1.0.3 version of hadoop

<code>
$hadoop version
Hadoop 1.0.3
Source http://mapr.com -r 68be2f84634a864ea19069f1a41e865c63fd3c15
Compiled by root on Wed May  8 19:22:38 PDT 2013
From source with checksum 1c056abd5505813df0386463b7aef213
</code>

I am trying to build release-3.3.0-mapr of Oozie
Trying to test
<pre>
$mvn -Dtest=TestActionCheckXCommand#testActionCheck test
</pre>
Getting following Errors :
<code>
-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Concurrency config is parallel='classes', perCoreThreadCount=false, threadCount=1, useUnlimitedThreads=false
Running org.apache.oozie.command.wf.TestActionCheckXCommand
Tests run: 7, Failures: 1, Errors: 2, Skipped: 0, Time elapsed: 33.433 sec <<< FAILURE!

Results :

Failed tests:   testActionCheckTransientDuringLauncher(org.apache.oozie.command.wf.TestActionCheckXCommand): expected:<0> but was:<1>

Tests in error:
  testActionCheck(org.apache.oozie.command.wf.TestActionCheckXCommand): java.lang.NullPointerException
  testActionCheckTransientDuringMRAction(org.apache.oozie.command.wf.TestActionCheckXCommand): java.lang.NullPointerException

</code>

I tried applying patch as as per https://issues.apache.org/jira/browse/OOZIE-1332
& also tried with setting umask 022.
Still getting same errors.

Please help.

Thanks,
Giridhar.

Outcomes