AnsweredAssumed Answered

mapr-hbase-dbclient issues

Question asked by thealy on Jul 22, 2013
Latest reply on Jul 23, 2013 by thealy
Running mapr-hbase 0.94.5.19793.GA

I'm testing a Java app which attempts to create and use HBase table. The code fails with this error (in NetBeans Debug):

<code>
Jul 22, 2013 11:59:02 AM org.apache.hadoop.hbase.client.mapr.TableMappingRulesFactory create
INFO: 'mapr-hbase-dbclient' package is required to access MapRDB tables.
</code>

I did some searching here in the forum and attempted to install what seems to be the missing package, mapr-hbase-internal:

<code>
sudo apt-get install  mapr-hbase-internal

Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mapr-hbase-internal : Depends: mapr_hbase but it is not installable

</code>

As you will see in dpkg output below, mapr_hbase seems to be installed.

As per another forum suggestion, I checked the MapR Entries in /etc/apt/sources.lst:
<code>
deb http://package.mapr.com/releases/v2.1.3/ubuntu/ mapr optional
deb http://package.mapr.com/releases/ecosystem/ubuntu binary/
</code>
Which have worked fine so far on this system.

But checking the installed packages, it shows mapr-hbase-internal, but I'm not sure what "rc" prefix to the line means. And the version looks suspect, but I don't know if or how to update it:
<code>
sudo dpkg -l |grep mapr

ii  mapr-core     2.1.3.19871.GA-1        amd64MapR:  Core binary package
ii  mapr-fileserver      2.1.3.19871.GA-1        amd64MapR:  Fileserver role package.
ii  mapr-hbase    0.94.5.19793.GA  all    MapR: HBase binary package
rc  mapr-hbase-internal  0.1-1     all    MapR: MapR HBase Internal
ii  mapr-metrics         2.1.3.19871.GA-1        amd64MapR: Metrics binary package
ii  mapr-pig      0.11.2.20832     all    Package to download Pig software on MapR Cluster.
ii  mapr-sqoop    1.4.3.20117      all    Package to download Sqoop software on MapR Cluster.
ii  mapr-tasktracker     2.1.3.19871.GA-1        amd64MapR:  Tasktracker role package
ii  mapr-webserver       2.1.3.19871.GA-1        amd64MapR:  MCS role package.
</code>
Can anyone help be get the client installed?

Thanks.

Outcomes