AnsweredAssumed Answered

MapR m3 failing to bootstrap in EMR

Question asked by whoahbot on May 5, 2013
Latest reply on May 6, 2013 by davidtucker
I'm trying to boot a cluster on EMR using the MapR M3 distribution. It seems as though others are having the same issue: https://forums.aws.amazon.com/thread.jspa?threadID=123656&tstart=0

I'm seeing these errors in maprcli-hadoop-106.log:

    Header: hostName: domU-12-31-39-15-34-55.compute-1.internal, Time Zone: Coordinated Universal Time, processName: MapRCLI, processId: 6777, MapR Build Version: 2.1.2.18401.GA
    2013-05-05 21:46:21,515 INFO  com.mapr.cliframework.driver.CLIMainDriver [main]: [node, list, -columns, hostname, -noheader]
    2013-05-05 21:46:21,540 INFO  com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils [main]: init
    2013-05-05 21:46:21,560 ERROR com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils getDataForParticularCLDB [main]: No data returned in RPC: CLDB Ips: 10.214.115.95-, Port: 7222. Continue searching for correct CLDB
    2013-05-05 21:46:21,562 INFO  com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils [main]: Bad CLDB credentials removed: CLDB Ips: 10.214.115.95-, Port: 7222
    2013-05-05 21:46:21,562 ERROR com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils getZkConnect [main]: No data is received from any cldb
    2013-05-05 21:46:21,562 ERROR com.mapr.cli.ServerCommands getServicesInfo [main]: zkConnectString is null/empty. Cannot proceed further.
    2013-05-05 21:46:21,577 INFO  com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils [main]: init
    2013-05-05 21:46:21,581 ERROR com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils getDataForParticularCLDB [main]: No data returned in RPC: CLDB Ips: 10.214.115.95-, Port: 7222. Continue searching for correct CLDB
    2013-05-05 21:46:21,581 INFO  com.mapr.baseutils.cldbutils.CLDBRpcCommonUtils [main]: Bad CLDB credentials removed: CLDB Ips: 10.214.115.95-, Port: 7222
    2013-05-05 21:46:21,581 ERROR com.mapr.cli.ServerCommands sendRequest [main]: RPC Request to list Nodes failed. No data returned
    2013-05-05 21:46:21,582 INFO  com.mapr.cliframework.driver.CLIMainDriver [main]: ERROR (10009) -  Couldn't connect to the CLDB service. Check if at least one CLDB is running.

Outcomes