AnsweredAssumed Answered

Which Sqoop

Question asked by rdominelli on May 3, 2013
Latest reply on May 6, 2013 by rdominelli
I am relatively new to the hadoop/mapr space.  I have pulled down M3 and installed it on a cluster and it seems to be working correctly (hive/hbase/mapreduce).

I am looking to install Sqoop and I am having a bit of tough time figuring out which version I should be using based on the hadoop version I am running as 1.4.3 requires you to select which hadoop version you are using.

If I run the command hadoop version I receive 1.0.3. Which sounds like I should be using Sqoop
sqoop-1.4.3.bin__hadoop-1.0.0.tar.gz. 

If I look in /opt/mapr/hadoop it looks like the version string is hadoop-0.20.2 and I should be using sqoop-1.4.3.bin__hadoop-0.20.tar.gz

I have tried both, and in both cases I receive

> Exception in thread "main" java.lang.IncompatibleClassChangeError: Found class > org.apache.hadoop.mapreduce.JobContext, but interface was expected


Which sounds like I am using the wrong version of sqoop based on the threads I am digging up through google. 

Has anyone gotten 1.4.3 to work on Mapr.  If so which version should I be using.

Thanks for your help.

Rich

Outcomes