AnsweredAssumed Answered

Inodes Limit Exceeded warning

Question asked by cleonn on Mar 21, 2013
Latest reply on Oct 22, 2013 by nabeel
We're receiving an Inodes Limit Exceeded warning on one volume. The thing is that the volume only contains 45 directories and 1 file. 44 of the directories are used as mount points to other volumes and the 45:th directory is empty.

Running:

<pre>maprcli volume info -name TheVolume -json</pre>

gives the following output:

<pre>{
"timestamp":1363869744613,
"status":"OK",
"total":1,
"data":[
  {
   "acl":{
    "Principal":"User srv",
    "Allowed actions":[
     "dump",
     "restore",
     "m",
     "d",
     "fc"
    ]
   },
   "creator":"srv",
   "aename":"srv",
   "aetype":0,
   "numreplicas":"2",
   "minreplicas":"2",
   "replicationtype":"high_throughput",
   "rackpath":"/",
   "readonly":"0",
   "mountdir":"/srv/00030000",
   "volumename":"TheVolume",
   "mounted":1,
   "quota":"0",
   "advisoryquota":"0",
   "snapshotcount":"0",
   "logicalUsed":"6036",
   "used":"6036",
   "snapshotused":"0",
   "totalused":"6036",
   "scheduleid":0,
   "schedulename":"",
   "volumetype":0,
   "volumeid":188457042,
   "actualreplication":[
    0,
    0,
    100,
    0,
    0,
    0,
    0,
    0,
    0,
    0,
    0
   ],
   "nameContainerSizeMB":5151,
   "needsGfsck":false,
   "maxinodesalarmthreshold":"0",
   "partlyOutOfTopology":0
  }
]
}</pre>

doesn't make me any wiser. Grepping for inode in logfiles doesn't yield anything either.

Is there a way to see why this alarm is set off? Or how to disable it?

Outcomes