AnsweredAssumed Answered

Problem configuring ephemeral disks on EC2

Question asked by heathbar on Mar 1, 2013
Latest reply on Mar 19, 2013 by heathbar
I'm trying to setup MapR to use the 4 ephemeral disks on an HPC EC2 instance but it only finds and uses 3 of them. 

I give it the full block device for xvdc, xvdd, xvde, but only a partition of xvdb (xvdb4).  The documentation seems to suggest that mapr can use partitions and not just full devices, and it seems like this has worked for me in the past (older versions of mapr different instance types).  I can't get MapR to use the storage on xvdb4 on this instance type and I'm not sure why.

Following the mapr whirr start_node script, xvdb1 is swap, xvdb2 and xvdb3 are mounted for core and log files respectively, leaving xvdb4 using the rest of the disk (~500 GB).

So my /tmp/disks.list contains...

<pre>
/dev/xvdb4
/dev/xvdc
/dev/xvdd
/dev/xvde
</pre>

Then I run the disksetup command...

<pre>
$ /opt/mapr/server/disksetup -C -F /tmp/disks.list
/dev/xvdc added.
/dev/xvdd added.
/dev/xvde added.
/dev/xvdb4 added.
</pre>

However, the web ui and the maprclip disk list command only shows /dev/xvdc, /dev/xvdd, /dev/xvde... I seem to be missing the 500GB that should be available on /dev/xvdb4.  Messing arround, if I remove /dev/xvde... the status message shows it has removed both /dev/xvde and /dev/xvdb4.  Any idea what is going on?


Running MapR v2.1.1

Outcomes