AnsweredAssumed Answered

/opt/mapr/logs/cldb.pid exists with pid 12280 but no CLDB.

Question asked by jyi on Oct 10, 2012
Latest reply on Oct 11, 2012 by jyi
Hi there!

Currently working on a 4 node cluster just to test out the new MapR v2.0.1.
I haven't had any issues during the installation portion but nothing seems to be working the way it should be, i can't even bring up the Web UI... CLDB is inactive but Zookeeper is running.
<pre>
/etc/init.d/mapr-cldb status

Output:
0.20.2
/opt/mapr/logs/cldb.pid exists with pid 12280 but no CLDB.

/etc/init.d/mapr-zookeeper status

Output:
JMX enabled by default
Using config: /opt/mapr/zookeeper/zookeeper-3.3.2/conf/zoo.cfg
zookeeper running as process 2000.


</pre>

Here are logs from various errors:

From cldb.log:
<pre>
java.net.NoRouteToHostException: No route to host
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)
at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1125)
2012-10-10 14:18:52,237 INFO CLDB [Thread-11]: CLDB ShutDown Hook called
2012-10-10 14:18:52,237 INFO ZooKeeperClient [Thread-11]: Zookeeper Client: Closing client connection:
2012-10-10 14:18:52,813 INFO ClientCnxn [main-SendThread(zmapr-c1n2:5181)]: Opening socket connection to server zmapr-c1n1/10.11.12.21:5181
2012-10-10 14:18:52,813 INFO ClientCnxn [main-SendThread(zmapr-c1n1:5181)]: Socket connection established to zmapr-c1n1/10.11.12.21:5181, initiating session
2012-10-10 14:18:52,928 INFO ZooKeeper [Thread-11]: Session: 0x0 closed
2012-10-10 14:18:52,928 INFO CLDB [Thread-11]: CLDB shutdown
2012-10-10 14:18:52,928 INFO ClientCnxn [main-EventThread]: EventThread shut down




From Warden.log:

2012-10-10 14:49:03,506 ERROR com.mapr.warden.WardenManager connect [main]: Could not connect to ZK within: 30000 ms. Check if ZK connection defined correctly: 10.11.12.21:5181,10.11.12.22:5181. No data from ZK will be returned.
2012-10-10 14:49:22,272 INFO  com.mapr.warden.centralconfig.PullCentralConfigTaskScheduler [PullCentralConfigTask]: /opt/mapr/server/pullcentralconfig process terminated with status: 0


Here are logs proving my successful installation:
cat maprinstall.log.1.summary
 - Checking command-line options ---
 - Checking repository for packages ---
 - Running pre-requisite checks ---
 - Installing packages ---
 - Setting up configuration ---
 - Running disksetup ---
 - Starting Zookeeper ---
 - Starting Warden ---
 Successfully installed and configured MapR on this node

cat maprinstall.log.summary
 - Checking command-line options ---
 ------ Installing MapR on node: 10.11.12.21 ------
 Successfully installed on node 10.11.12.21
 Testing ssh to 10.11.12.22
 ------ Installing MapR on node: 10.11.12.22 ------
 Successfully installed on node 10.11.12.22
 Testing ssh to 10.11.12.23
 ------ Installing MapR on node: 10.11.12.23 ------
 Successfully installed on node 10.11.12.23
 Testing ssh to 10.11.12.24
 ------ Installing MapR on node: 10.11.12.24 ------
 Successfully installed on node 10.11.12.24



Outcomes