AnsweredAssumed Answered

Can not map Mapr FS directory to a windows drive

Question asked by sand on Sep 23, 2012
Latest reply on Sep 23, 2012 by nabeel
when I map the shared /mapr/my.cluster.com
directory onto a windows drive, I can not make it success, neither on
windows XP nor on windows 7.

The following is the detail:

1. on windows XP I installed SFU(service for unix) and configured name mapping, but when I
mount the /mapr/my.cluster.com in command line:
<pre>
mount -o nolock \\\\192.168.0.108\\mapr\\my.cluster.com z:
</pre>
I got error "Network error - 31", which represents " A device attached to
the system is not functioning"
I changed my cmd line as:
<pre>
mount -o nolock 192.168.0.108:/mapr/my.cluster.com z:
mount -o nolock mapr-desktop:/mapr/my.cluster.com z:
</pre>
etc.
The same error occurred.

* on windows 7

The same as above ,but no name mapping is configured, the error I got is :

I get error " network error - 53", which represents " Network path not found ".

I changed input command line as did in windows XP, the same error occurred.

But either in windows 7 or in windows XP, when I mounted another
directory(another host ,in the same network segment) exported by normal NFS,
it succeeded.

I try using UI to map network drive , but no go either.

Outcomes