AnsweredAssumed Answered

M3: Could not find MapR packages in the repository. Configure the repository correctly and retry.

Question asked by jameson on Sep 19, 2012
Latest reply on Sep 19, 2012 by nabeel
My M3 roles file:

<pre>
ma1.h.com mapr-metrics,mapr-cldb,mapr-webserver,mapr-nfs,mapr-jobtracker /dev/sdb
hd1.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd2.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd3.h.com mapr-fileserver,mapr-tasktracker,mapr-zookeeper /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd4.h.com mapr-fileserver,mapr-tasktracker,mapr-zookeeper /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd5.h.com mapr-fileserver,mapr-tasktracker,mapr-zookeeper /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd6.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd7.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd8.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd9.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
hd10.h.com mapr-fileserver,mapr-tasktracker /dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1,/dev/sdf1,/dev/sdg1,/dev/sdh1,/dev/sdi1,/dev/sdj1
</pre>
Yesterday I downloaded the yesterday's newest maprinstall file from http://archive.mapr.com/releases/v2.0.0/maprinstall.
And it works find, but it needs the dependencies about this:
<pre>
  mysql-connector-java >= 5.1.0
  sdparm
  soci-mysql
</pre>
So I stoped my installation, and tell our ops team to help me to install these dependencies package.

* My first question: why mapr installation not slove these needed dependencies package itself? should I install these myself? Or somewhere my wrong configuation?

Today I repeat install the mapr, and using this command './maprinstall -R mycluster.roles -F -u root -N mycl', but it all long prompt that:"Could not find MapR packages in the repository. Configure the repository correctly and retry.". And I found that the yum repo file that download by the install script yesterday:

[mapr]
name=MapR Technologies
baseurl=http://package.mapr.com/releases/v2.0.0/redhat
enabled=1
gpgcheck=0
protect=1

But the file today:

[mapr]
name=MapR Technologies
baseurl=http://archive.mapr.com/releases/v2.0.1/redhat
enabled=1
gpgcheck=0
protect=1

* My second question: yesterday I have install many times run maprinstall, I can see it just down one time the repo file, but today there are so many repo files, why? Anywhere wrong?:
<pre>
ll -rt /etc/yum.repos.d/ |grep mapr
-rw-r--r-- 1 root root 124 Sep 19 18:44 mapr-eco.26850.repo
-rw-r--r-- 1 root root 117 Sep 19 18:44 mapr.26850.repo
-rw-r--r-- 1 root root 124 Sep 20 10:39 mapr-eco.16613.repo
-rw-r--r-- 1 root root 117 Sep 20 10:39 mapr.16613.repo
-rw-r--r-- 1 root root 124 Sep 20 10:52 mapr-eco.16935.repo
-rw-r--r-- 1 root root 117 Sep 20 10:52 mapr.16935.repo
-rw-r--r-- 1 root root 124 Sep 20 11:02 mapr-eco.17806.repo
-rw-r--r-- 1 root root 117 Sep 20 11:02 mapr.17806.repo
-rw-r--r-- 1 root root 124 Sep 20 11:06 mapr-eco.18499.repo
-rw-r--r-- 1 root root 117 Sep 20 11:06 mapr.18499.repo
-rw-r--r-- 1 root root 117 Sep 20 11:20 mapr-eco.21671.repo
-rw-r--r-- 1 root root 117 Sep 20 11:20 mapr.21671.repo
-rw-r--r-- 1 root root 117 Sep 20 11:23 mapr-eco.22797.repo
-rw-r--r-- 1 root root 117 Sep 20 11:23 mapr.22797.repo
-rw-r--r-- 1 root root 117 Sep 20 11:32 mapr-eco.26372.repo
-rw-r--r-- 1 root root 117 Sep 20 11:32 mapr.26372.repo
-rw-r--r-- 1 root root 117 Sep 20 11:42 mapr-eco.27914.repo
-rw-r--r-- 1 root root 117 Sep 20 11:42 mapr.27914.repo
</pre>
After I change the install file from v2.0.1: 'http://archive.mapr.com/releases/v2.0.1/maprinstall', but it still prompt error.

* My third question: How can I make maprinstall work?

The prompt error log info:
Yesterday:
<pre>
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package mapr-metrics.x86_64 0:2.0.0.15153GA-1 set to be updated
--> Processing Dependency: mapr-core >= 0.0.1.1-1 for package: mapr-metrics
--> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics
--> Processing Dependency: soci-mysql for package: mapr-metrics
---> Package mapr-cldb.x86_64 0:2.0.0.15153GA-1 set to be updated
--> Processing Dependency: mapr-fileserver >= 0.0.1.1-1 for package: mapr-cldb
---> Package mapr-nfs.x86_64 0:2.0.0.15153GA-1 set to be updated
---> Package mapr-webserver.x86_64 0:2.0.0.15153GA-1 set to be updated
--> Processing Dependency: Ajaxterm = 0.10-8.el5 for package: mapr-webserver
---> Package mapr-jobtracker.x86_64 0:2.0.0.15153GA-1 set to be updated
--> Running transaction check
---> Package mapr-metrics.x86_64 0:2.0.0.15153GA-1 set to be updated
--> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics
--> Processing Dependency: soci-mysql for package: mapr-metrics
---> Package mapr-core.x86_64 0:2.0.0.15153GA-1 set to be updated
--> Processing Dependency: sdparm for package: mapr-core
---> Package mapr-fileserver.x86_64 0:2.0.0.15153GA-1 set to be updated
---> Package Ajaxterm.noarch 0:0.10-8.el5 set to be updated
--> Finished Dependency Resolution
mapr-core-2.0.0.15153GA-1.x86_64 from mapr has depsolving problems
  --> Missing Dependency: sdparm is needed by package mapr-core-2.0.0.15153GA-1.x86_64 (mapr)
mapr-metrics-2.0.0.15153GA-1.x86_64 from mapr has depsolving problems
  --> Missing Dependency: soci-mysql is needed by package mapr-metrics-2.0.0.15153GA-1.x86_64 (mapr)
mapr-metrics-2.0.0.15153GA-1.x86_64 from mapr has depsolving problems
  --> Missing Dependency: mysql-connector-java >= 5.1.0 is needed by package mapr-metrics-2.0.0.15153GA-1.x86_64 (mapr)
Error: Missing Dependency: soci-mysql is needed by package mapr-metrics-2.0.0.15153GA-1.x86_64 (mapr)
Error: Missing Dependency: sdparm is needed by package mapr-core-2.0.0.15153GA-1.x86_64 (mapr)
Error: Missing Dependency: mysql-connector-java >= 5.1.0 is needed by package mapr-metrics-2.0.0.15153GA-1.x86_64 (mapr)
</pre>

Today info:
<pre>
Logging to /opt/mapr/logs/maprinstall.log, /opt/mapr/logs/maprinstall.log.summary


 --- Checking command-line options
     Done

 --- Parsing roles file
     Done


 --- Installing MapR on node: ma1.h.com ---
     For install status, refer to ma1.h.com:{/opt/mapr/logs/maprinstall.log.1, /opt/mapr/logs/maprinstall.log.1.summary}
     - Checking command-line options ---
     - Checking repository for packages ---
    
    
     Could not find MapR packages in the repository. Configure the repository correctly and retry.
     Failed to install on node: ma1.h.com
</pre>

Outcomes