AnsweredAssumed Answered

Can not access the Control System GUI after changing HTTP configuration

Question asked by akusanagi Employee on Sep 18, 2012
Latest reply on Sep 19, 2012 by yufeldman
The default settings of /opt/mapr/conf/web.conf is like this:

    #
    #Tue Apr 17 21:03:49 JST 2012
    mapr.webui.auth.pam.profiles=mapr-admin,sudo,sshd
    mapr.webui.https.keystorepassword=mapr123
    mapr.webui.https.keystorepath=/opt/mapr/adminuiapp/webapp/WEB-INF/ssl_keystore
    mapr.webui.timeout=1800
    mapr.headerbuffer.size=16384
    mapr.webui.https.port=8443
    web.host=0.0.0.0

Once you open the Configure HTTP dialog in the Control System and save a configuration, /opt/mapr/conf/web.conf will become like this:

    #
    #Wed Sep 19 11:07:18 JST 2012
    mapr.webui.auth.pam.profiles=mapr-admin,sudo,sshd
    mapr.webui.https.keystorepassword=****
    mapr.webui.https.keystorepath=/opt/mapr/adminuiapp/webapp/WEB-INF/ssl_keystore
    mapr.webui.timeout=1800
    mapr.webui.http.port=8080
    mapr.headerbuffer.size=16384
    mapr.webui.https.port=8443
    web.host=0.0.0.0

We have a problem here 'mapr.webui.https.keystorepassword=`****`' because it causes to disable HTTPS accesses (after rebooting the webserver process). It should be a plain text in web.conf.

I'm not sure how this is related to the system configuration value that you can set by the 'maprcli config' command, but replacing web.conf with the original configuration simply fixed the problem.

My MapR version is 2.0.

Outcomes