AnsweredAssumed Answered

HBase client installation not working

Question asked by dave_kincaid on Aug 21, 2012
Latest reply on Aug 21, 2012 by dave_kincaid
I'm trying to follow the directions at http://www.mapr.com/doc/display/MapR/HBase to install the HBase client on a machine outside the cluster (my laptop). When I follow the directions for Ubuntu and use the 2.0.0 repository my system tells me that mapr-hbase-internal is not an available package:

    Package mapr-hbase-internal is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'mapr-hbase-internal' has no installation candidate

Our cluster is currently 1.2.9, so I'd thought I'd try using the 1.2.9 repository. When I try to install mapr-hbase-internal from there (after uninstalling the 2.0 client and installing the 1.2.9 client) it gives me this error:

    dpkg: error processing /var/cache/apt/archives/mapr-core_1.2.9.14720.GA-0_amd64.deb (--unpack):
     trying to overwrite '/opt/mapr/NOTICE.txt', which is also in package mapr-client 1.2.9.14720.GA-0
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Selecting previously unselected package mapr-hbase-internal.
    Unpacking mapr-hbase-internal (from .../mapr-hbase-internal_1.2.9.14720.GA.v0.90.6-0_amd64.deb) ...
    Errors were encountered while processing:
     /var/cache/apt/archives/mapr-core_1.2.9.14720.GA-0_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

Any advice for how to proceed with either of these installs? We're going to be upgrading our cluster to 2.0 soon, so that would be the preferred route for me.

Outcomes