AnsweredAssumed Answered

Issue with maprinstall script

Question asked by harish on Aug 27, 2012
Latest reply on Aug 28, 2012 by abhinav
Hi,

I was trying to install mapr 2.0.0 on a 7 node cluster using the maprinstall script as root. Had created a user named mapr on all 7 nodes. Passed the mapr user as argument for -u flag (as mentioned in the requirements page http://www.mapr.com/doc/display/MapR/Installing+MapR+Software#InstallingMapRSoftware-execute )

I ran it this way >
 
    /opt/install-mapr/maprinstall -R roles -F -N mapr-nextgen.com -u mapr -f -p <my local repo path>

The script installed the services mentioned in roles file for the first node alone successfully. For all other nodes, it was saying ssh failed for node xx.xxx.xxx.xxx .  From the error I could see that it is trying to ssh to the other nodes as the mapr user ( as specified in -u .. I doubt ssh should ideally be done as root user itself as the script tries to mkdir inside /opt folder inside the nodes.)

However, I ran it without -u option and was able to finish the installation on all nodes (as root user) after resolving few dependency errors that the script was complaning about on the nodes.

Is this a bug with the script or was it my fault with passing proper arguments to the script ?

Outcomes