AnsweredAssumed Answered

Ganglia cannot communicate between meta and monitored nodes

Question asked by anil_bhargava on Apr 24, 2012
Latest reply on Aug 5, 2015 by tpho
Problem : The installation was pretty smooth using yum but I have a problem with connectivity between gmond and gmetad. I have a cluster to monitor, made up of three virtual machines (viz. ClusterM, node1, node2) having centOS 5. All three of them are having gmond running and gmetad is running on clusterM which is head node. But Meta node is able to see(on web) only local gmond host for clusterM only (itself).
I have tried the "telnet localhost 8694" to check the XML on all nodes and find that its generating fine then tried the "telnet localhost 8651" on meta node for gmetad but its showing the XML for itself only.

Details are as follows : 

clusterM : 192.168.122.30
node1 : 192.168.122.82
node2 : 192.168.122.77

The configuration of gmetad (on clusterM 192.168.122.30):

data_source "my cluster" 300 192.168.122.30:8649 192.168.122.82:8649 192.168.122.77:8649

The configuration of gmond(on clusterM, node1 & node2):

cluster {
  name = "my cluster"
  owner = "unspecified"
  latlong = "unspecified"
  url = "unspecified"
}

/* The host section describes attributes of the host, like the location */
host {
  location = "unspecified"
}

/* Feel free to specify as many udp_send_channels as you like.  Gmond
   used to only support having a single channel */
udp_send_channel {
  #bind_hostname = yes # Highly recommended, soon to be default.
                       # This option tells gmond to use a source address
                       # that resolves to the machine's hostname.  Without
                       # this, the metrics may appear to come from any
                      # interface and the DNS names associated with
                       # those IPs will be used to create the RRDs.
  mcast_join = 239.2.11.71
  port = 8649
  ttl = 1
}

/* You can specify as many udp_recv_channels as you like as well. */
udp_recv_channel {
  mcast_join = 239.2.11.71
  port = 8649
  bind = 239.2.11.71
}

/* You can specify as many tcp_accept_channels as you like to share
   an xml description of the state of the cluster */
tcp_accept_channel {
  port = 8649
}

Coz i m a beginner in this field I've tried various configuration options for both gmond & gmetad available on web but none of them worked for me..! 

What I'm missing here?
post a reply or mail me at [anilbhargava777@gmail.com][1]
Many Thanx in advance...:)

Submitted By :
Anil Bhargava
anilbhargava777@gmail.com


  [1]: http://anilbhargava777@gmail.com//anilbhargava777@gmail.com

Outcomes