AnsweredAssumed Answered

MapR CLi service list command always returns status as NOT_CONFIGURED even when services are Running

Question asked by ghousia on Mar 5, 2012
Latest reply on Feb 12, 2015 by prinsonpv
I am running MapR on a small cluster of 3 nodes (node1, node2, node3. node1 as master) MapR Service list command (maprcli) when run on node1 for node2 always returns status 0 for all the services. But there are actually services running on that node

Running from node1:
<pre>
/opt/mapr/bin/maprcli service list -node node2

name         state  logpath                              displayname
fileserver   0      /opt/mapr/logs/mfs.log               FileServer
nfs          0      /opt/mapr/logs/nfsserver.log         NFS Gateway
webserver    0      /opt/mapr/logs/adminuiapp.log        Webserver
cldb         0      /opt/mapr/logs/cldb.log              CLDB
tasktracker  0      /opt/mapr/hadoop/hadoop-0.20.2/logs  TaskTracker
jobtracker   0      /opt/mapr/hadoop/hadoop-0.20.2/logs  JobTracker
hoststats    0      /opt/mapr/logs/hoststats.log         HostStats
</pre>
Running from node2:
<pre>
/opt/mapr/bin/maprcli service list -node node2
name         state  logpath                              displayname
fileserver   2      /opt/mapr/logs/mfs.log               FileServer
nfs          0      /opt/mapr/logs/nfsserver.log         NFS Gateway
webserver    0      /opt/mapr/logs/adminuiapp.log        Webserver
cldb         0      /opt/mapr/logs/cldb.log              CLDB
tasktracker  2      /opt/mapr/hadoop/hadoop-0.20.2/logs  TaskTracker
jobtracker   0      /opt/mapr/hadoop/hadoop-0.20.2/logs  JobTracker
hoststats    2      /opt/mapr/logs/hoststats.log         HostStats

Outcomes