AnsweredAssumed Answered

Zookeeper Client Authentication Issues

Question asked by chris.crawford on Jul 9, 2018
Latest reply on Jul 17, 2018 by MichaelSegel

MapR Community--

 

I am attempting to stand-up one of the various apache products on my cluster, however, when the client attempts to access ZK, I get the same error as posted here:  org.apache.zookeeper.client.ZooKeeperSaslClient: An error:

 

I had to disable MapR Security to get the client to work on my cluster, but obviously, I'd like to turn MapR Security back on.

 

My best guess is that when security is enabled, ZK asks for a ticket and is expecting a MapR ticket, however, the client tries to send a Kerberos ticket instead.  I'm guessing that the client tries to send the tickets stored in /opt/mapr/conf/mapr.keytab, but those are Kerberos tickets and not a "MapR ticket" so ZK errors.

 

**BTW--I have copied the mapr.login.conf file to my client's directory and pass that as the JAAS file so that I can make modifications to that file without hosing up my cluster**

 

Theoretically, I think that I should be able to modify the client's version of the mapr.login.conf to force the client to send the MapR ticket.

 

Anyone know how to do that?  And is this even the right solution?

Outcomes