AnsweredAssumed Answered

How to restart installation when mapr-installer.service fails?

Question asked by ebe on May 28, 2018
Latest reply on May 29, 2018 by Mufy

I followed the installation procedures as per the basic instructions.

$ wget http://package.mapr.com/releases/installer/mapr-setup.sh  -P /tmp
$ sudo bash /tmp/mapr-setup.sh

All dependencies were installed successfully and I was able to run the installation process through the https://nodename:9443/ link. The process failed at the verification step stating that the space for /opt/mapr/ is insufficient. So, I deleted that mapr directory, mounted a new partition in /opt and wanted to restart the installation process. This time, the local installation link doesn't open as the job for mapr-installer.service failed because the control process exited with error code.

 

I even tried deleting the mapr user along with its /home/mapr directory and trying the whole process afresh but still no luck. Attached to this question is the output along with "systemctl status mapr-installer.service" and "journalctl -xe".

 

Is there any way to undo all changes made by the first time I tried to install MapR and start afresh? I am worried that there could be some broken links after executing the "sudo rm -rf /opt/mapr". 

 

May I know how to solve this problem?

Attachments

Outcomes