AnsweredAssumed Answered

importJSON quietly fails for no reason

Question asked by thompsjj on May 20, 2018
Latest reply on May 30, 2018 by cathy

Hi,

 

I'm just getting started learning MapR-DB (otherwise experienced) and I'm running into a bit of trouble right away that I'm unable to overcome. I'm working on the Docker image.

 

Working through the DEV330 lab guide, I'm trying to load the sample data for Lesson 1. After 

 

mapr@maprdemo:~$ wget http://course-files.mapr.com/DEV3300-R1/Lesson1.zip

mapr@maprdemo:~$ unzip -o Lesson1.zip

 

(Works fine, obviously, and yes I checked the file contents) I then try

 

mapr@maprdemo:~$ mapr importJSON -src /tmp/artists/*.* -dst /apps/artists -bulkload true

 

Which fails, only outputting the following:

 

PARSE ARGS: /tmp/artists/00034ede-a1f1-4219-be39-02f36853373e.json

Usage: importJSON [options] -src <Input text file/directory path> -dst <MapR-DB Destination table path>

Options:

[-idfield <Name of ID field in JSON Data>]

[-bulkload <true|false>, default is false]

[-mapreduce <true|false>, default is true]

(Can not use bulkload mode with mapreduce = false)

(If no ID field is specified, an ID field is expected to be present in the JSON Record)

 

This seems to imply that mapr cannot parse my command completely, but I can't find anything at all on why this would be happening or how to improve it. I'm completely stuck. Can anyone help? This makes no sense at all to me. I've tried everything I can think of to try to make it work, only ever getting the same result.

Outcomes