AnsweredAssumed Answered

Drill with Plain Authentication failed by JDBC in Zeppelin

Question asked by stobe on Apr 19, 2018
Latest reply on Apr 23, 2018 by Rachel Silver

I try to access to my drillbit with Plain Authentication from zeppelin on Docker [data-science-refinery:v1.2_6.0.1_5.0.0_centos7].

But I'm facing below error:

java.sql.SQLException: [MapR][DrillJDBCDriver](500150) Error setting/closing connection. Details: Client needs authentication but server doesn't support any security mechanisms. Please contact your administrator. [Warn: It may be due to wrong config or a security attack in progress.]

         :

Caused by: com.mapr.drill.support.exceptions.GeneralException: [MapR][DrillJDBCDriver](500150) Error setting/closing connection. Details: Client needs authentication but server doesn't support any security mechanisms. Please contact your administrator. [Warn: It may be due to wrong config or a security attack in progress.]
... 29 more
Caused by: com.mapr.drill.support.exceptions.ErrorException: foo1:31010
at com.mapr.drill.drill.client.DRJDBCClient.openSession(Unknown Source)

  :

at java.lang.Thread.run(Thread.java:748)
When I access with No Authentication , no error.
By sqlline , I can access drillbit whether Plain Authenticaiton or No Authentication.

$ sqlline -u "jdbc:drill:drillbit=foo1:31010;auth=Plain" -n mapr -p mapr
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=512M; support was removed in 8.0
apache drill 1.10.0

Do you know how to fix this problem ?
Plain Authentication is expired in zeppelin on data-science-refinery ?
MapR core : 5.2.2
Drill : 1.10.0.
/opt/mapr/drill/drill-1.10.0/conf/drill-override.conf:

drill.exec: {
  cluster-id: "dev-mr-drillbits",
  zk.connect: "foo1:5181,foo2:5181,foo3:5181",
  impersonation: {
          enabled: true,
          max_chained_user_hops: 3
        },
  security: {
        auth.mechanisms : ["PLAIN"],
         },
  security.user.auth: {
        enabled: true,
        packages += "org.apache.drill.exec.rpc.user.security",
        impl: "pam",
        pam_profiles: [ "sudo","login" ]
        drill.exec.security.user.encryption.sasl.enabled: false
   }
}

Interpreter setting

Outcomes