AnsweredAssumed Answered

ERROR: The node /hbase is not in ZooKeeper

Question asked by shrilesh.naik on Mar 22, 2018
Latest reply on Mar 26, 2018 by cathy

Hi,

 

When we configure Hbase with default db "hbase" we are gettting this error. Works fine with default db as "maprdb"

 

Property in hbase-site.xml :

 

<property>
<name>mapr.hbase.default.db</name>
<value>maprdb</value>
</property>

 

Error :

 

HBase Shell; enter 'help<RETURN>' for list of supported commands.
Type "exit<RETURN>" to leave the HBase Shell
Version 1.1.8-mapr-1710, r2c52ca3f992cced95f36b11d7b04b86474ad9ed0, Sun Nov 12 23:59:09 UTC 2017

Not all HBase shell commands are applicable to MapR tables.
Consult MapR documentation for the list of supported commands.

hbase(main):001:0> list
Listing HBase tables. Specify a path or configure namespace mappings to list M7 tables.
Unable to connect to HBase services.
TABLE

ERROR: The node /hbase is not in ZooKeeper. It should have been written by the master. Check the value configured in 'zookeeper.znode.parent'. There could be a mismatch with the one configured in the master.

Here is some help for this command:
List all tables in hbase. Optional regular expression parameter could
be used to filter the output. Examples:#

hbase> list
hbase> list '/tables/t.*'

Outcomes