AnsweredAssumed Answered

Could not access Drill with Plain Authentication via ODBC driver

Question asked by stobe on Mar 5, 2018
Latest reply on Mar 6, 2018 by stobe

Hi , I trying to access Drill with Plain Authentication. But I get authentication failed.

I'm setting PLAIN Authentication in drill-override.conf but server seem like no authentication.

On Drill web console , Authentication is on and I can log in.

Do I have to do more setting for ODBC ?

Drill version is 1.10

 

 

Error message:
[28000][unixODBC][MapR][Drill] (30) User authentication failed. Server message: [30024]Client needs a secure connection but server does not support any security mechanisms. Please contact an administrator. [Warn: This could be due to a bad configuration or a security attack is in progress.]
[ISQL]ERROR: Could not SQLConnect

 

/opt/mapr/drill/drill-1.10.0/conf/drill-override.conf :

drill.exec: {
cluster-id: "foo-drillbits",
zk.connect: "foo1:5181,foo2:5181,foo3:5181",
impersonation: {
enabled: true,
max_chained_user_hops: 3
},
security: {
auth.mechanisms : ["PLAIN"],
},
security.user.auth: {
enabled: true,
packages += "org.apache.drill.exec.rpc.user.security",
impl: "pam",
pam_profiles: [ "sudo","login" ]
}
}

.odbc.ini :

[MapR Drill 64-bit]
Description=MapR Drill ODBC Driver (64-bit) DSN
Driver=/opt/mapr/drill/lib/64/libdrillodbc_sb64.so
DriverUnicodeEncoding=2
ConnectionType=Zookeeper
ZKQuorum=foo1:5181,foo2:5181,foo3:5181
ZKClusterID=foo-drillbits
AuthenticationType=Plain
UID=mapr
PWD=mapr
DelegationUID=
AdvancedProperties=CastAnyToVarchar=true;HandshakeTimeout=5;QueryTimeout=180;TimestampTZDisplayTimezone=utc;ExcludedSchemas=sys,INFORMATION_SCHEMA;NumberOfPrefetchBuffers=5;
Catalog=DRILL
Schema=
SSL=0
DisableHostVerification=0
DisableCertificateVerification=0
TrustedCerts=/opt/mapr/drill/lib/64/cacerts.pem
TLSProtocol=
UseSystemTrustStore=0

 

 

Thanks in advance,

Outcomes