AnsweredAssumed Answered

Error while installing MapR 6.0

Question asked by shansara on Feb 23, 2018
Latest reply on Mar 8, 2018 by abizer_adenwala
Branched to a new discussion

Hello,

 

While installing MapR 6.0 version, I get the error "ERROR: Unable to install dependencies (installer). Ensure that a core OS repo is enabled and retry mapr-setup.sh"

Please can you shed some light to resolve this error?

 

[root ~]# ./mapr-setup.sh

MapR Distribution Initialization and Update

Copyright 2018 MapR Technologies, Inc., All Rights Reserved
http://www.mapr.com

Install required packages? (y/n) [y]: y

Installing installer package dependencies...

Warning: RPMDB altered outside of yum.
warning: /etc/pki/java/cacerts created as /etc/pki/java/cacerts.rpmnew
warning: /etc/pki/tls/certs/ca-bundle.crt created as /etc/pki/tls/certs/ca-bundle.crt.rpmnew
warning: /etc/pki/tls/certs/ca-bundle.trust.crt created as /etc/pki/tls/certs/ca-bundle.trust.crt.rpmnew
Please ignore warnings about /etc/pki/java/cacerts.rpmnew, they are expected as the new consolidated configuration feature is enabled
Please ignore warnings about /etc/pki/tls/certs/ca-bundle.crt.rpmnew, they are expected as the new consolidated configuration feature is enabled
Please ignore warnings about /etc/pki/tls/certs/ca-bundle.trust.crt.rpmnew, they are expected as the new consolidated configuration feature is enabled
Package curl-7.19.7-53.el6_9.x86_64 already installed and latest version
Package initscripts-9.03.58-1.el6_9.2.x86_64 already installed and latest version
Package net-tools-1.60-114.el6.x86_64 already installed and latest version
Package sudo-1.8.6p3-29.el6_9.x86_64 already installed and latest version
Package wget-1.12-10.el6.x86_64 already installed and latest version
Package which-2.19-6.el6.x86_64 already installed and latest version
Package openssh-clients-5.3p1-123.el6_9.x86_64 already installed and latest version
Package openssh-server-5.3p1-123.el6_9.x86_64 already installed and latest version
Error: Package: sshpass-1.06-1.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.15)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

ERROR: Unable to install dependencies (installer). Ensure that a core OS repo is enabled and retry mapr-setup.sh

 

Thanks

Outcomes