AnsweredAssumed Answered

Error While using kafka-connect-jdbc

Question asked by Sanjay0004 on Feb 19, 2018
Latest reply on Mar 7, 2018 by cathy

Hi All,

 

I was able to successfully establish a connection between Hana and MapR Streams using kafka-connect-jdbc when I used my local MapR Sandbox, but when  I am trying this on the MapR server its not executing properly and running into the below warning without any output:

 

 

I was getting REST server already in use: so I changed the port number to 8084.

 

I am also attaching my connect-standalone.properties below:

 

# These are defaults. This file just demonstrates how to override some settings.

bootstrap.servers=localhost:9092

# The converters specify the format of data in Kafka and how to translate it into Connect data. Every Connect user will

# need to configure these based on the format they want their data in when loaded from or stored into Kafka

key.converter=org.apache.kafka.connect.json.JsonConverter

value.converter=org.apache.kafka.connect.json.JsonConverter

# Converter-specific settings can be passed in by prefixing the Converter's setting with the converter we want to apply

# it to

key.converter.schemas.enable=false

value.converter.schemas.enable=true

# The internal converter used for offsets and config data is configurable and must be specified, but most users will

# always want to use the built-in default. Offset and config data is never visible outside of Copcyat in this format.

internal.key.converter=org.apache.kafka.connect.json.JsonConverter

internal.value.converter=org.apache.kafka.connect.json.JsonConverter

internal.key.converter.schemas.enable=false

internal.value.converter.schemas.enable=false

offset.storage.file.filename=/tmp/connect.offsets

# Flush much faster than normal, which is useful for testing/debugging

offset.flush.interval.ms=1000

rest.port=8084 

 

Please let me know, how to fix this issue. Looking forward for your valuable suggestions on this.

 

Best Regards,

Sanjay 

Outcomes