AnsweredAssumed Answered

Webhcat start failed with error

Question asked by shiv on Jan 27, 2018
Latest reply on Jan 31, 2018 by maprcommunity

Mathieu Dumoulin

Hi Guys, 

I am facing an issue with webhcat, not able to access it on browser using url

http://webcathost:50111/templeton/v1/status?user.name=mapr 

Services are running fine, In MCS I can see webhcat server is up and running but when I tried to restart it from cli using webhcat-server.sh, it was started but I found following issue in webhcat-console-error.log

SLF4J: Class path contains multiple SLF4J bindings.

SLF4J: Found binding in [jar:file:/opt/mapr/hive/hive-2.1/lib/log4j-slf4j-impl-2.4.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]

SLF4J: Found binding in [jar:file:/opt/mapr/lib/slf4j-log4j12-1.7.12.jar!/org/slf4j/impl/StaticLoggerBinder.class]

SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.

SLF4J: Actual binding is of type [org.apache.logging.slf4j.Log4jLoggerFactory]

2018-01-28 12:13:24,416 main ERROR Unable to locate appender "INFO,standard" for logger config "root"

Exception in thread "main" @java.lang.NoSuchMethodError: com.sun.jersey.core.reflection.ReflectionHelper.getOsgiRegistryInstance()Lcom/sun/jersey/core/osgi/OsgiRegistry;

at com.sun.jersey.spi.scanning.AnnotationScannerListener$AnnotatedClassVisitor.getClassForName(AnnotationScannerListener.java:217)

at com.sun.jersey.spi.scanning.AnnotationScannerListener$AnnotatedClassVisitor.visitEnd(AnnotationScannerListener.java:186)

at org.objectweb.asm.ClassReader.accept(Unknown Source)

at org.objectweb.asm.ClassReader.accept(Unknown Source)

at com.sun.jersey.spi.scanning.AnnotationScannerListener.onProcess(AnnotationScannerListener.java:136)

at com.sun.jersey.core.spi.scanning.JarFileScanner.scan(JarFileScanner.java:97)

at com.sun.jersey.core.spi.scanning.uri.JarZipSchemeScanner$1.f(JarZipSchemeScanner.java:78)

at com.sun.jersey.core.util.Closing.f(Closing.java:71)

 

 

I replaced all jersey-core-1.9.jar(has no method such getOsgiRegistryInstance) with 1.14 jars for Hadoop still no luck. Has anyone faced this issue or this is a bug in mapr5.2.1? Please help me.

Outcomes