AnsweredAssumed Answered

MapR installer script shutdown function does not work/hangs

Question asked by reedv on Jan 26, 2018
Latest reply on Jan 29, 2018 by maprcommunity

Trying to use the mapr installer script to shut down a running cluster, it is showing behavior that I think is not right (though I have never successfully used this feature before).

 

Immediately after clicking the shutdown button in the main menu, a grayed-out screen appears (which shows all of the nodes on it with a spinning gears) on top of which a text pane warns that shutting down the cluster will take it offline (sorry I don't have many pictures, since did not expect any problems and it did not seem safe to just backout from the browser). After clicking 'ok' on the overlapping pane, the screen looks like below:

Now, before even entering a password or pressing a button, the spinning icon at the top is already spinning and entering in the password and clicking 'Shutdown' raises an error in the UI saying 

An error occurred:

Process already running-Error code:400

and moving cursor over the '<-- Previous' and 'Shutdown' buttons raises text saying "Can't proceed until all processes are completed". This has been going for ~30min without change.

This is what I see in /opt/mapr/installer/logs/installer-processes.log:

 

2018-01-26 09:19:51.460: * 09:19:51: running play Stop all services for Retry/Upgrade
===============================================================================
= =
= __ __ ____ ___ _ _ _ =
= | \/ | __ _ _ __ | _ \ |_ _| _ __ ___ | |_ __ _ | || | ___ _ __ =
= | |\/| | / _` || '_ \ | |_) | | | | '_ \ / __|| __|/ _` || || | / _ \| '__|=
= | | | || (_| || |_) || _ < | | | | | |\__ \| |_| (_| || || || __/| | =
= |_| |_| \__,_|| .__/ |_| \_\ |___||_| |_||___/ \__|\__,_||_||_| \___||_| =
= |_| =
= =
===============================================================================
Version: 1.7.9


2018-01-26 09:20:00.635: User accepted: <strong>WARNING</strong><br/><br/> This will shutdown your MapR cluster by stopping all services. <br/> Are you sure you wish to continue?
2018-01-26 09:20:17.988:
2018-01-26 09:20:51.931: * 09:20:51: running play Stop all services for Retry/Upgrade
2018-01-26 09:23:20.788: * 09:23:20: running play Starting maintenance update
2018-01-26 09:23:21.331: * 09:23:21: running play Configuring package repository
2018-01-26 09:23:24.671: * 09:23:24: running play Configuring package repository
2018-01-26 09:23:24.692: * 09:23:24: running play Configuring package repository
2018-01-26 09:24:23.044: * 09:24:23: running play Configuring package repository
2018-01-26 09:24:23.057: * 09:24:23: running play Installing MapR Core
2018-01-26 09:24:42.220: * 09:24:42: running play Configuring MapR services
2018-01-26 10:06:30.805:
(END)

Notice the last recorded time is 10:06, yet when I ran this command, it was 10:30.

Can no loner access the MCS, Grafana, Drill web UI, YARN web UI, NFS, etc., but I can't tell if there is a problem or not (eg. only working in some ways) or if it is just really slow. Does anyone have any explanation for this? Any ideas how long it is supposed to take to run? Thanks.

Outcomes