AnsweredAssumed Answered

Issue calling mkdirs

Question asked by boucherj on Jan 2, 2018
Latest reply on Jan 9, 2018 by maprcommunity
Branched from an earlier discussion

I'm having a similar issue when calling mkdirs, except that it complains that the versions are different when they seems to be the same ???:

 

2018-01-02 20:23:29,9468 ERROR JniCommon fs/client/fileclient/cc/jni_MapRClient.cc:616 Thread: 6051 Mismatch found for java and native libraries java build version 5.2.2.44680GA, native build version 5.2.2.44680.GA java patch vserion $Id: mapr-version: 5.2.2.44680GA 44680:b0ba7dcefd80b9aaf39f05f3, native patch version $Id: mapr-version: 5.2.2.44680.GA 44680:b0ba7dcefd80b9aaf39f05f
2018-01-02 20:23:29,9469 ERROR JniCommon fs/client/fileclient/cc/jni_MapRClient.cc:626 Thread: 6051 Client initialization failed.
Caught: java.io.IOException: Could not create FileClient
java.io.IOException: Could not create FileClient
at com.mapr.fs.MapRFileSystem.lookupClient(MapRFileSystem.java:626)
at com.mapr.fs.MapRFileSystem.lookupClient(MapRFileSystem.java:679)
at com.mapr.fs.MapRFileSystem.makeDir(MapRFileSystem.java:1239)
at com.mapr.fs.MapRFileSystem.mkdirs(MapRFileSystem.java:1276)
at org.apache.hadoop.fs.FileSystem.mkdirs(FileSystem.java:1917)
at org.apache.hadoop.fs.FileSystem$mkdirs$0.call(Unknown Source)

 

The client is on CentOS:

Linux cqjw-3d8412bd8 3.10.0-514.6.1.el7.x86_64 #1 SMP Wed Jan 18 13:06:36 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

[cqjw-3d8412bd8 mapr]$ cat /etc/*-release
CentOS Linux release 7.3.1611 (Core)

VERSION="4.6.1"

The client MapR version:

[cqjw-3d8412bd8 mapr]$ cat /opt/mapr/MapRBuildVersion
5.2.2.44680.GA

 

The cluster is on RHEL:

Linux dev-mapr-01 3.10.0-327.44.2.el7.x86_64 #1 SMP Thu Nov 24 05:49:35 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
[dev-mapr-01]$ cat /etc/*-release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.2 (Maipo)"

The cluster MapR version:

[dev-mapr-01]$ cat /opt/mapr/MapRBuildVersion
5.2.2.44680.GA

 

How can I further debug this?  I've tried ignoring the version as specified in Troubleshooting 

<property>   <name>fs.mapr.bailout.on.library.mismatch</name>   <value>false</value>   <description>Disabling to continue running jobs</description> </property>

But it gives the same error message.

 

The same code is working fine from a Windows MapR client with the sandbox/demo cluster:

 

[mapr@maprdemo ~]$ cat /opt/mapr/MapRBuildVersion
5.2.2.44680.GA

 

Thanks,

 

Jacques

Outcomes