AnsweredAssumed Answered

Deployment error on Azure

Question asked by elldekaa on Dec 19, 2017
Latest reply on Dec 21, 2017 by elldekaa

Hi all,

I got an error when trying to deploy a cluster on Azure (using the Marketplace).

{ "status": "Failed", "error": { "code": "ResourceDeploymentFailure", "message": "The resource operation completed with terminal provisioning state 'Failed'.", "details": [ { "code": "DeploymentFailed", "message": "At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.", "details": [ { "code": "Conflict", "message": "{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"VMExtensionProvisioningError\",\r\n \"message\": \"VM has reported a failure when processing extension 'mapr-installer'. Error message: \\\"Enable failed: failed to execute command: command terminated with exit status=1\\n[stdout]\\nMapR user from properties file is: 'mapr'\\nMapR user from file owner is: 'mapr'\\nA MapR user was found so this installation will proceed as a prepped image install.\\nUsers match: 'mapr' = 'mapr'\\nUser 'mapr' exists\\nMapR user is: mapr\\nPassword changed\\nMEP: 4.0.0\\nCLUSTER_NAME: mytestdemapr.cluster.com\\nMAPR_PASSWORD: <hidden>\\nTHREE_DOT_SUBNET_PRIVATE: 10.1.4.\\nSTART_OCTET: 4\\nNODE_COUNT: 3\\nSERVICE_TEMPLATE: template-05-converged\\nRESOURCE_GROUP: vamoslamichel-gp\\nADMIN_AUTH_TYPE: password\\nMAPR_USER: mapr\\nSUBSCRIPTION_ID: 1c368a84-15de-49d4-aa23-b832276b5c17\\nTENANT_ID: 45f5dc2c-07a2-44de-9f25-944dbf0b55e4\\nLICENSE_TYPE: M3\\nOS: redhat\\nIS_PREPPED: true\\nNODE_LIST: [\\\"10.1.4.4\\\", \\\"10.1.4.5\\\", \\\"10.1.4.6\\\"]\\nUpgrading MapR installer if necessary...\\nbuild_version: 6.0.0.20171109191718.GA\\nChecking MapR packager version RedHat\\npackage_version: 6.0.0.20171109191718.GA-1.x86_64\\nBuild file version: '6.0.0'\\nPackage version: '6.0.0'\\nVersions match: 6.0.0 = 6.0.0\\nFinal MapR Core version: '6.0.0'\\nMAPR_CORE: 6.0.0\\nWaiting for successful connection: 1\\nWaiting for successful connection: 2\\nWaiting for successful connection: 3\\nWaiting for successful connection: 4\\nHTTP/1.1 200 OK\\r\\nDate: Tue, 19 Dec 2017 10:40:53 GMT\\r\\nContent-Type: text/html\\r\\nLast-Modified: Thu, 09 Nov 2017 06:20:46 GMT\\r\\nAccept-Ranges: bytes\\r\\nContent-Length: 2379\\r\\nServer: Jetty(9.2.z-SNAPSHOT)\\r\\n\\r\\nMapR template-05-converged selected; Installation starting...\\nERROR: Could not run installation: 1\\n\\n[stderr]\\nCreated symlink from /etc/systemd/system/multi-user.target.wants/mapr-installer.service to /etc/systemd/system/mapr-installer.service.\\nRedirecting to /bin/systemctl start mapr-installer.service\\nERROR: install command failed\\ntoo many values to unpack\\nLog files mapr-installer.log and installer-cli.log can be found at /opt/mapr/installer/logs\\n\\\".\"\r\n }\r\n ]\r\n }\r\n}" } ] } ] } }

Here is the log of the installation (/opt/mapr/installer/logs/installer-cli.log)

2017-12-19 10:40:55 : INFO : MapR Installer SDK
2017-12-19 10:40:55 : DEBUG : Running on Linux as user mapr.
2017-12-19 10:40:55 : INFO : Logging in to localhost
2017-12-19 10:40:58 : DEBUG : Cookie: MAPRJSESSIONID=1ecced7a-9e1e-4dda-a511-8dea1e48edd0
2017-12-19 10:41:01 : ERROR : install command failed
too many values to unpack
Log files mapr-installer.log and installer-cli.log can be found at /opt/mapr/installer/logs
Traceback (most recent call last):
  File "/opt/mapr/installer/bin/mapr-installer-cli.py", line 330, in execute
    self.inst_exec()
  File "/opt/mapr/installer/bin/mapr-installer-cli.py", line 352, in inst_exec
    self.read_template()
  File "/opt/mapr/installer/bin/mapr-installer-cli.py", line 120, in read_template
    self.read_overrides()
  File "/opt/mapr/installer/bin/mapr-installer-cli.py", line 150, in read_overrides
    self.setval_template(override)
  File "/opt/mapr/installer/bin/mapr-installer-cli.py", line 198, in setval_template
    key_nest, val = dot_obj.split('=')
ValueError: too many values to unpack

I haven't done anything fancy with the configuration so I'm wondering if someone may have an idea...

Thanks

Outcomes