AnsweredAssumed Answered

Is Java 1.8 required for Drill 1.11 JDBC client?

Question asked by MilindTakawale on Dec 12, 2017
Latest reply on Dec 19, 2017 by takeshi



We are evaluating MapR 6.0 and one of the main bottlenecks seems to be requirement of Java 1.8 for 1.11 Drill JDBC Client.


According to this reference, to use MapR 6.0 we need MEP 4.0.0. And this link suggests we would require Drill 1.11 along with it. To take advantage of new encrypted communication between drill-client and drill-bits, we have gone for "Drill JDBC Driver by MapR" instead of "Apache Drill's open source JDBC driver": reference 1, reference 2


In our testing we found out one of the classes (ClusterCoordinator) of dependency "drill-java-exec" is expecting ConcurrentHashMap.keySet() to return KeySetView, which is not true for Java 1.7, where a Set is returned instead. 


Now upgrading to Java 8 is not a trivial task for us, so before we throw idea of using MapR 6.0 out of the window, just wanted to confirm if we are not missing anything.


Please let us know, If there is a way we can move to MapR 6.0, without upgrading our Java clients to Java 1.8


mapr 6.0, mapr drill, jdbc